"503 Response object too large" error

On 9ec9d474, I tried

$ nix-build -A python3Packages.pytorchWithCuda
copying path '/nix/store/z4r9j5ld8fx3ksgyb53hp7nwdxy3zjpd-cuda_10.2.89_440.33.01_linux.run' from 'https://cache.nixos.org'...
warning: error: unable to download 'https://cache.nixos.org/nar/0g3mvx4rg81g9fdcjc5822v14vf73lnr84fcbxa8jdgciqa1m3qk.nar.xz': HTTP error 503 ('')

       response body:

       <?xml version="1.0" encoding="utf-8"?>
       <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
           <title>503 Response object too large</title>
           <h1>Error 503 Response object too large</h1>
           <p>Response object too large</p>
           <h3>Guru Mediation:</h3>
           <p>Details: cache-sea4482-SEA 1645776736 3111971108</p>
           <p>Varnish cache server</p>
       </html>; retrying in 332 ms

What does this error mean? It looks to be a networking issue, but I’m getting it consistently when trying to build pytorchWithCuda.

The error means, that the size of the nar is to big for the CDN. Therefore it’s denying the transfer.

Sadly I am unsure how to fix, other than disabling the CDN.

How does one build these packages in this case?

Use --option substituters "" to disable substituters, cancel build after the one that fails the download has been built, cancel, start build again with substituters enabled, get at least parts of the remaining stuff from the cache…

Though, I’m curious… The name of the path entry looks as if this was actually something used as src somewhere… I’m wondering why it even is tried to get substituted. That shouldn’t happen usually, at least not if the thing built from it is in the cache. So either the thing built from those sources is not in the cache (in which case we need to check if there are reasons for keeping the sources in there and instead let people download them locally) or if the build entry is in the cache, then we need to check, why the sources are part of the runtime closure and fix the build to not keep any references.

1 Like

Why open a new discussion thread instead of using this one? Cache.nixos.org responds with 503

I wasn’t aware of the prior thread