Aarch64 build of kodi doesn't run through qemu

Posting here to look for help with an issue I raised on github. I’m currently using an x86_64 box running Arch to manage deployments to a couple of raspberry pi 4’s with nixops. I’ve set up systemd-binfmt to cross-compile packages to aarch64 as needed. This setup has worked fine so far, but I’ve run into a snag trying to compile kodi for an HTPC box (and replace my LibreELEC install with a Nixos install). There’s a checkInstallPhase section that tries to run kodi --version after compiling everything, but as soon as the build process gets there it hangs and never finishes.

I also tried pulling down an aarch64 build from hydra and running --version on the same machine (through qemu-aarch64-static again) and saw the same behavior – it prints the version info, then just hangs. So I feel fairly confident it’s a problem with the nix-built package through qemu-aarch64-static, but I’m still not clear on whether this is an issue with nix or qemu (or kodi for that matter).

So far I’m making do with an overrideAttrs to set doCheckInstall to false and skip the whole thing, but I’d still appreciate any help sorting out why this is happening.