Adding idea-community from nixpkgs-unstable

I ran into a bug with idea-community but when I try to install 2019.2.3 from unstable I am still getting 2019.2.1. This is the configuration:

# nix-channel --list
  unstable = import <nixpkgs> {};
in {environment.systemPackages = with pkgs; [

Is it possible the channel is not updated with the newer version set in github?

Are you running nix-channel --list as your user and nixos-rebuild as root?
Different users have different channels.

No this is all as root. My user doesn’t have any channels.

Have you recently run nix-channel --update?
What does nix-instantiate --eval -E '(import <nixpkgs> {}).lib.version' say?

Sorry for the late response. I haven’t had time to mess with this lately.

Have you recently run nix-channel --update?

I have updated the channels several times.

What does nix-instantiate --eval -E '(import <nixpkgs> {}).lib.version' say?

The result is:


I changed my config to use packageOverrides to add unstable.

  3   nixpkgs.config = {                                                            
  4     allowUnfree = true;                                                         
  5     packageOverrides = pkgs: {                                                  
  6       unstable = import <nixpkgs> {                                             
  7         config = config.nixpkgs.config;                                         
  8       };                                                                        
  9       nur = import <nur> {                                                      
 10         inherit pkgs;                                                           
 11       };                                                                        
 12     };                                                                          
 13   }; 

But I still get the same results.

This is interesting

# nix-instantiate --eval -E '(import <nixpkgs> {}).lib.version'
# nixos-version
19.09.941.27a5ddcf747 (Loris)

It looks like nixpkgs and nixos are at the same commit.

I was able to fix this but I’m not sure how. I imported nixos-unstable and then had to switch home-manager to use it for that package.