Anbox install problem?

i tried to install anbox but failed to build becouse it marked as broken…but i look at hydra build evrythings is green…why?? any suggestion??.. :slightly_smiling_face:

What channel and perhaps commit are you on?

What looked you at in hydra?

here hydra 20.09 my default channel…evrythings is green

here hydra unstable and its top 3 is green…

but when i install its fail marked broken…

Hydra doesn’t attempt building packages that are marked as broken. BTW, last time I checked anbox was unmaintained and stuck at Android 7.

but it was maintain by edward tjornhammar and the last succesfull build was 5 days ago… :slightly_frowning_face:

Not build, evaluation. The attribute still evaluates, but it isn’t built because its broken.

At least this would be my understanding of it.

Though I just took a look at the derivation, it is not marked as broken (on master)…


$ nix build nixpkgs#anbox
$ nix build nixpkgs/nixos-unstable#anbox
$ nix build nixpkgs/nixos-20.09#anbox

All three builds suceeded without a problem, they even got downloaded from cache.

Are you sure you tried 20.09 and unstable branches @paklie?

PS and edit: I skimmed commit history from master. The package never has been marked as broken there. Please tell us exactly which channel you are trying to install from and how.

anbox upstream was abandoned (see also Status of the project? · Issue #1748 · anbox/anbox · GitHub). Development has pretty much ceased since October 2018.

Indeed, hydra built anbox successfully and building locally on NixOS 20.09 succeeds for me as well using

nix-build '<nixpkgs>' --check -A anbox

with --check to prevent substitution from the binary cache. My channel is on 20.09.20210222.d4189f6.

1 Like

sorry guys…my bad…after examine the error i found it fail on build the dependencies kernel modul ashmem…when i check from gihub page, it is marked failed… :sweat_smile: