Anjuta can't see glib

Hi, I’m abolutely new NixOS user so my problem may be trivial.
I’ve got new Gnome NixOS installation plus some software. I installed Anjuta and one by one rest of the packages it required. Except on. If I trie to build any project Anjuta spits out below error:

Error: You must have `glib’ installed.

I think I’ve got glib installed:


Has anybody any idea how to get it sorted out?

How do you try to build it?

And re the patches you have shown, just because something exists in the store, that doesn’t mean that your current environment can see it.

Same way as on other distros. First I tried to use template to see if Anjuta works for me. App required some packages to create project, I added one by one packages to:


then run:

nixos-rebuild switch

and this way worked well for me except this one package.

What exactly did you add to configuration.nix? Libraries? That won’t work:

Instead you have to properly package Anjuta.

Though someone else already did that:

So you can just add it to your environment.systemPackages.