Asciidoc fail tests on one nixos machine

Hi there,
i am trying to play around with hydra and thus rebuilding my system. So i installed hydra on one (that’s just the situation why i at that problem, but i dont see a relation to that).

On one particular system i am failing on the test of asciidoc and i really dont get why.
The machine follows nixos-unstable and is configured via this flake GitHub - Shawn8901/nix-configuration . The affected machine is called tank.

The test of asciidoc is failing on the comparison of the generated timestamps of the documentation and the error is looking like this

asciidoc> SOURCE: asciidoc: tests/inputs/lang-pt-BR-test.txt
asciidoc> PASSED: docbook: tests/data/lang-pt-BR-article-test-docbook.xml
asciidoc> PASSED: docbook5: tests/data/lang-pt-BR-article-test-docbook5.xml
asciidoc> FAILED: xhtml11: tests/data/lang-pt-BR-article-test-xhtml11.html
asciidoc> +++ tests/data/lang-pt-BR-article-test-xhtml11.html
asciidoc> — got
asciidoc> - 2002-11-25 00:37:42 UTC
asciidoc> + 1980-01-02 00:00:00 UTC

The asciidoc package of nixpkgs is patching the tests/inputs files so that they contain the timestamp 1980-01-02 00:00:00 UTC (see nixpkgs/default.nix at da5b47eba8ad4ad30dbc0de17dd1f64ccc07f0f3 · NixOS/nixpkgs · GitHub).

On all machines i try to build the package with nix build github:shawn8901/nix-configuration#nixosConfigurations.tank.pkgs.asciidoc --print-build-logs --rebuild

Other machines (e.G pointalpha) do build that package fine without any test fails.
So it seems somehow to me, that on the failing machine the package behaves different and really dont understand why thats the case.
I dont know if its somehow relevant but my nix.conf of that machine looks like this:

# WARNING: this file is generated from the nix.* options in
# your NixOS configuration, typically
# /etc/nixos/configuration.nix.  Do not edit it!
allowed-users = *
auto-optimise-store = true
builders = 
cores = 4
experimental-features = nix-command flakes
extra-sandbox-paths = 
keep-derivations = true
keep-outputs = true
max-jobs = 2
netrc-file = /run/agenix/nix-netrc
require-sigs = true
sandbox = true
sandbox-fallback = false
substituters =
system-features = gccarch-x86-64-v2 gccarch-x86-64-v3 benchmark big-parallel kvm nixos-test
trusted-public-keys = nixos:vjrrtYYXDQx4qWPPQ0BeO2cr/O/VCkqOWgbFe2bPfi4=
trusted-substituters = 
trusted-users = hydra-queue-runner root shawn
!include /run/agenix/github_access_token
extra-allowed-uris =

The non-failing machine differs in the extra-allowed-uris (not set) and keep-derivations and keep-outputs (both not set) and hydra-queue-runner as additional trusted user (see nix.conf - Diff Checker).

If I remove the patching of the tests (replacement of the substitute) the package builds fine.

I somehow suspect the sandbox being broken.
nix store verify --all -no-trust returns no errors.
The drv of the package is /nix/store/xq8wsi07q4sq66lal4z315ymgdwsyclm-asciidoc-10.2.0.drv which matches Hydra - Log of step 1 of build 203942212 of job nixpkgs:python-updates:asciidoc.x86_64-linux

Does by chance someone has an idea whats wrong with my machine or any input where I could continue to search for the issue?
I appreciate every help or input.

Those settings should not matter.

In nixpkgs or where?

Yes, i did checkout nixpkgs on the commit where the flake is locked at and then changed the code (removing the substitue like described).
Then i build the package from that local nixpkgs. Tests pass in that situation.
Repeating that on any other nixos machine, do fail on the same modification.

So for me it looks like that on that special machine, something with the EPOCH loading is different, but i can not find a difference.

So i tried to check if its something in the flake config or something impure from the machine, therefor i reinstalled the system (which was quite easy as its a impernance setup anyways).
Happly or sadly (depending on the point of view) the issue is gone after reinstallation.
As i reduced the system before to a absolute minimum (having a base install + openssh) and the issue was persisting i have the impression that it was something wrong with the store.

Another package i found behaving differently was jq, which was tried to be installed with bison/yacc, which is not in our install instruction, thus it was failing with a file not found.

Where it possibly got broken was when i moved my nix store on my FS, as i tried to mitigate issue python310Packages.jpylyzer fails to build on zfs · Issue #205780 · NixOS/nixpkgs · GitHub . But i dont see where it could have gone wrong there.

Nevertheless the issue seems to be gone, thank for the input so far Sandro :slight_smile: