Asus Zenbook Duo (2024 / UX8406MA) & NixOS

Hi, set up backlight with systemd daemon process, works well! Sorry flickering might not be the word to describe it, i mean like sensitive to light when it occassually dims or brightness screen a bit according to some ambient light changes when i supposedly dont do anything, might be totally the window shades.

Anyhow, everything is looking very good, the last thing which would be nice would be backlight for keyboard, but on windows it did light up only when attached anyway *shrugs

Are you sure the flickering is not what I described here?

No im pretty sure. But havent worked enough with pc, will keep ur post in mind in case…

I have narrowed down the 6.9 secondary display problem to this merge commit. I will bisect further when I get time.


The auto flickering i am referring to is the brightness bar in upper right menu jumping up and down, when the auto-brightness is enabled. It doesn’t seem to stay constantly on one value, at least not when im in total darkness, one theory was that it might be light reflecting from me but doesn’t seem so. So from what i read i think this is clearly not the flickering you were referring to. On windows there is not such a problem, i tried one of your mentioned solutions of adding the psr property, but did not help.

6.9.4 still no go. Bottom display is just a black image.


Tried 6.9.5 and got the exact same behavior: bottom display is just black although reported as enabled. Plasma 6 on Wayland and X11 tested. Also tried 6.10-rc3 from linux_testing briefly and got the exact same behavior. 6.8.12 is rock solid. I wonder if this is a regression that will continue onward kernel releases (6.9 / 6.10 etc…). I have an external ssd, I’ll try Aurora (ublue) there with 6.9 and report back.

1 Like

Is there an appropriate channel to report the bottom display issue? 6.10-rc4 still presents the issue. I’m afraid this regression will be unresolved indefinitely since I imagine the Zenbook Duo being somewhat a niche product and we may end up stuck on 6.8.


Interesting observation, when I first got the second monitor enabled in Hyprland, I immediately noticed flickering (grays getting brighter and dimmer rapidly).

Just out of curiosity I tried enabling VRR, which I have disabled in my Hyprland config, and it actually resolved the flickering.

I have VRR disabled because on all my other computers, enabling VRR causes flickering, so this was unexpected.

misc {
    vrr = 1 # Somehow this laptop flickers when vrr *not* enabled

Blacklisting asus_nb_wmi stops the rfkill when connecting/disconnecting the keyboard:

boot.blacklistedKernelModules = [
  "asus_nb_wmi" # Kills the Wi-Fi any time I connect the keyboard

Volume controls still work in wireless mode so I’m not sure if I lose anything by disabling this module.

1 Like

It could be that enabling VRR limits the effects of PSR, which also causes flickering. I turn both off and have no flickering on KDE.

1 Like

Good to know that the keypress is actually handled by an ASUS-specific kernel module. We could probably just add some code to disable that key on this device.