Basic help installing Nix

Help help help…

Stuck installing Nix in a NixOS Proxmox VM I just installed from nixos-minimal-21.11.334821.d887ac7aee9-x86_64-linux.iso

After sh <(curl -L --daemon I’m ending with a:

oh no!
Jeeze, something went wrong. If you…

And errors seems to be a ton of:

cp: cannot create directory '/nix/store/...': Read-only file system

Found around it can be solved pointing the $out variable to a /tmp subdirectory, but I don’t have a clue on where is it or how to do it, so, help help help…



Wait, why are you trying to install nix on NixOS? NixOS comes with nix built in. Perhaps I’m missing something?

1 Like

If you wanted to upgrade the version of nix used by the VM you’d use something like nix-env -iA nix_2_4, or set nix.package to nix_2_4 and use nixos-rebuild (by far the preferred option IMO).

It’s worth reading the post-installation section of the manual.

Yes indeed Sam, you are missing something: my ignorance :slight_smile:

Thing is, I’m following the instructions to install a bundle of Nix apps (nix-bitcoin), but I didn’t knew Nix/NixOS existed before getting there, so I ‘missinterpreted’ some of the instructions. Your clarification was enough to ‘unstock’ me and I think I’m almost done, gratitude

Ah well I’m glad that it worked out for you! Getting set up can be quite confusing at first