Bluetooth broken in recent master? [solved]

I run my laptop on the unstable channel, and I use a Bluetooth Low Energy keyboard. It seems that recent changes cause my keyboard to no longer connect. Bluetooth works fine and sees new devices but not my already-paired keyboard.

I did some upgrades without rebooting and this morning a thermal event forced a reboot and then I noticed. Of course, thanks to NixOS being super awesome, I could just boot previous generations and I found that the breakage happens sometime between 21.03pre246062.420f89ceb26 and nixos-21.03pre250162.34ad166a830.

The comparison is https://github.com/NixOS/nixpkgs/compare/420f89ceb26...34ad166a830 but GitHub crashes on that :frowning:

I don’t have time right now to investigate further, does this ring any bells for anyone?

I’ve been having a similar problem with an Apple Magic Trackpad on 20.09. The trackpad will pair, but then my computer won’t actually see any input from it.

Weirdly, my issue was fixed (at least temporarily) by rebooting into 20.03 and then back into 20.09. I only found this fix by accident and can’t even begin to explain it.

1 Like

I got it to work by unpairing and re-pairing. Hmm.

1 Like