Can't boot NixOS Server anymore


I have NixOS on a Hetzner Cloud Server.
I was working on some files via SSH (only html files, nothing system relevant) and got disconnected.

Tried to reconnect via SSH and got locked out.
I checked the Hetzner cloud console and it is only showing the “grub rescue” promt.

I tried to find the boot partition but all I got with “ls” is
“Filesystem is ext32” for example.

Did anybody know a solution here?
Would be great -.-
Thank you

Boot from the nixos .iso

and what are the steps after this?

It’s really no different from how you would troubleshoot any other Linux distribution.

There’s a good write-up for Arch which covers a lot of ground:

Hetzner has a recovery mode where it will boot your currently installed OS in a virtual machine on the same hardware. This is quite useful to debug boot and network issues. It will provide you with a web ui. I think it was called something with KVM.
This advice was for hetzner baremetal. For cloud you already have a nice console…