Cant install github-desktop

Using nixos 6.1.34. When I run

nix-shell -p github-desktop


error: Package ‘openssl-1.1.1u’ in /nix/var/nix/profiles/per-user/root/channels/nixos/pkgs/development/libraries/openssl/default.nix:210 is marked as insecure, refusing to evaluate.

       Known issues:
        - OpenSSL 1.1 is reaching its end of life on 2023/09/11 and cannot be supported through the NixOS 23.05 release cycle.

       You can install it anyway by allowing this package, using the
       following methods:

       a) To temporarily allow all insecure packages, you can use an environment
          variable for a single invocation of the nix tools:

            $ export NIXPKGS_ALLOW_INSECURE=1

        Note: For `nix shell`, `nix build`, `nix develop` or any other Nix 2.4+
        (Flake) command, `--impure` must be passed in order to read this
        environment variable.

       b) for `nixos-rebuild` you can add ‘openssl-1.1.1u’ to
          `nixpkgs.config.permittedInsecurePackages` in the configuration.nix,
          like so:

              nixpkgs.config.permittedInsecurePackages = [

       c) For `nix-env`, `nix-build`, `nix-shell` or any other Nix command you can add
          ‘openssl-1.1.1u’ to `permittedInsecurePackages` in
          ~/.config/nixpkgs/config.nix, like so:

              permittedInsecurePackages = [
(use '--show-trace' to show detailed location information)

Just installed Nixos yesterday, so need help. I have tried searching for this but cant see anything. Everything else is working fine. Also, I note that the response is incorrect since I tried to follow the recommended steps above without success, but thats a minor issue.

What was the exact thing you tryed?

The proposed fix in a) should work in so far that nix tries to build everything, including the old and insecure libssl.

1 Like

I first try to put the gihub-desktop in my configuration.nix but it would not build, so I simply put the line as shown above in a bash shell.

I also tried to put a) in my configuration.nix file as is and it didnt work and I have not yet figured out what the syntax is that makes it work. But then again I dont want to use an outdated package, so my question is how is it supposed to work? Without allowing insecure package as I dont think thats the right way to have a reliable secure system.

You can’t put solution A with your system configuration, there you need to use B.

A is suitable for the oneshot shell.

And as far as I am aware the GH Desktop app is currently not compatible with a newer SSL.

There is currently nothing you can do, but not using it.

Thank you, a nice clear response.