CF card reader not recognized

This is a USB3 reader. It works well in Linux but not recognized by Nix. lsblk does not show it, nor does sg_scan -i

Tried adding kernel modules “ehci-hcd” “uhci-hcd” “ohci-hcd” “usb-storage” “scsi” “usb” but reader still not recognized.

Could there be another module I’m missing?

So you see anything in




when you plug it in?

if the kernel can’t see it being plugged in at the level, these’s no way your going to see as a block device.

what kind of card reader is it, might be a weird one that doesn’t have any support in linux :-(.
(so i can avoid it in the future).

does it work in any other linux?

dmesg show a USB device with read/8 error -71, which I presume is the card reader.

Again, it works out-of-the-box with Linux and even with FreeBSD stock systems.

could be a power issue? If it has external power try that, if it’s a laptop, trying plugging into the mains?

if not, it’s gotta be some kind of kernel issue.

give us the output of your logs for reference.

After about 50 rebuild switches changing options, Nix sees the reader but it’s not clear why.

I did hardware.firmwareAllEnable which activated the CF reader. But then commenting out this line the reader stayed active, even with reboots.

Now removing the “usb” module deactivates the reader, and adding “usb” activates it. But with “usb” module active, I get a build error that says there is no usb module found.

It’s not fatal and the system finishes build and boots fine, although the message “no usb module found” come up during the boot scroll.

I tried reordering the modules, but it’s always the “usb” module that seems to determine if the reader works.

It’s confusing.