Choose unstable for option-activated package without <package>.namePkg option

Specifically I want to use unstable podman, and tried including this (with import virtualisation.nix), where that file’s contents is:

# definitions for virtualisation
{ config, pkgs, ... }:

    unstable = import <nixos-unstable> { config = { allowUnfree = true; }; }; # unstable for virtualisation because podman has new fixes

    virtualisation = {
        podman = {
            enable = true;
            dockerCompat = true;

    environment.systemPackages = with unstable; [
        # podman

If I specify podman I get (non-fatal) colission messages, which I understand is because podman.enable already pulls in the podman package. However, there is no podman.package option to specify something like podman.package = unstable.podman, so how do I override it?

Additionally, I’d prefer to define unstable = import ... once (in configuration.nix, which imports all sub-configs) and refer to it in the sub-configs, (I tried { config, pkgs, unstable, ...}: at the top, but that doesn’t seem to work, maybe I have misunderstood the function of that line in all config files?)