Compile next browser from 19.09 stable version?

There is still no next in 19.09.
So, I bring in the nixpkgs as below like…

      next-gtk-webkit = pkgs.callPackage /nixpkgs/pkgs/applications/networking/browsers/next-gtk-webkit {};
      next = with self; pkgs.callPackage /nixpkgs/pkgs/applications/networking/browsers/next {next-gtk-webkit=next-gtk-webit;sbcl=sbcl;lispPackages=pkgs.lispPackages;}; #cl-css=cl-css;

ERROR part in next/default.nix,

In version 19.09 there is no cl-css in the lispPackages module.

So we’re going to replicate & edit the next/default.nix to another location… so I Attempts to force callPackage (pkgs.lispPackages.cl-cs) to install cl-css. result failed same.

Can’t you install it?

(next required nixpkgs’s dependencies (packages that exist only in github unstable version)
.
cl-css cl-hooks cl-prevalence log4cl lparallel mk-string-metrics str trivia trivial-clipboard unix-opts )

Thanks

You have to generate these lisp packages. You can look at https://github.com/NixOS/nixpkgs/tree/master/pkgs/development/lisp-modules.
Since adding a new lisp package update all of them, I would prefer to avoid doing this in a stable release. Also, it’s really easy to install Next from the unstable channel:

nix-env -f channel:nixpkgs-unstable -i next

Morever, you could also get the last Next release from the unstable channel, and Next is moving fast currently.

2 Likes

Thank you for the answer.
However, I tried installing “next” , but I get an error on window so crash next-browser at starting immediatly.
.
you’ve given you the correct answer(how to setup lisp-modules), but I’m still not sure how to install quicklisp’s lisp modules in configuration.nix.
.
What I want to know is is that way to install lisp-modules in configuration.nix?
.
Or manage package modules (such as default.nix) in other nix files
Isn’t there a detailed way?

It’s not clear to me what you want to achieve.
Could you explain what you want to do exactly, what is your final objective?

Also, are you able to use the next browser from the unstable channel (with the nix-env above command)? Is it working as expected? If not, could you open an issue?

1 Like