Consistent session-c1.scope fail for User lightdm

Stable 22.05 user here, with kde as desktop manager + lightdm as display manager with wayland. I have home-manager to manage users. Lately I have this consistent error (although the error doesn’t seem to capsize anything, I can still login OK):

$ sudo systemctl --failed
  UNIT             LOAD   ACTIVE SUB    DESCRIPTION               
● session-c1.scope loaded failed failed Session c1 of User lightdm

LOAD   = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB    = The low-level unit activation state, values depend on unit type.
1 loaded units listed.

Can anyone guess why the above error is happening? Do I need some additional declaration with respect to lightdm? packagekit and update-locatedb services occasionally fail as well, but seem to survive a restart, sudo systemctl restart packagekit.service update-locatedb.service.

Here’s the relevant section of my configuration.nix. Some statements I understand, but others I don’t, at least not fully (still trying to master nix language). Would appreciate any insights, comments (particularly if something seems odd):

{ config, pkgs, callPackage, ... }:{
  nixpkgs.config = {
    allowUnfree = true;   
    permittedInsecurePackages = [
      "electron-9.4.4"
    ];
  };

  imports =
    [ # Include the results of the hardware scan.
      ./hardware-configuration.nix
      <home-manager/nixos>
    ];
  boot.loader.grub.enable = true;
  boot.loader.grub.version = 2;
  boot.loader.grub.device = "/dev/sdc"; # or "nodev" for efi only
  boot.loader.grub.gfxmodeBios = "1920x1080,1280x1024,auto";
  boot.loader.grub.gfxpayloadBios = "keep";
  boot.initrd.kernelModules = [ "amdgpu" ];
 
  services = {
    avahi = {
      enable = true;
      nssmdns = true;
    };
    xserver = {
      enable = true;
      layout = "us";
      videoDrivers = [ "amdgpu" ];
      desktopManager.plasma5 = {
        enable = true;
      };
      displayManager = {
        defaultSession = "plasmawayland";
        lightdm = {
          enable = true;
          greeter.enable = true;
        };
      };
    };
    cron = {
      enable = true;
      systemCronJobs = [
        "0 * * * * /run/current-system/sw/bin/updatedb"
      ];
    };
    interception-tools.enable = true;
    printing = {
      enable = true;
      drivers = with pkgs; [
        canon-cups-ufr2
      ];
    };
    locate = {
      enable = true;
      localuser = null;
      locate = pkgs.mlocate;
      pruneNames = [ ".git" ".tmp" ];
      prunePaths = [ "/tmp" "/var/cache" "/var/lock" "/var/run" "/var/spool" "/run/media" "/plex" ];
      interval = "hourly";
    };
    openssh.enable = true;

   # I've commented this next statement out, as I assumed `packagekit` was automatically enabled elsewhere (I get the `systemd session` regardless). 
    # packagekit.enable = true;
    dbus.packages = [ pkgs.dconf ];
  };

  security.pam.services = {
    lightdm-greeter.enableKwallet = true;
    lightdm.enableKwallet = true;
    lightdm.enableGnomeKeyring = true;
    kwallet = {
      name = "kwallet";
      enableKwallet = true;
    };
  };

Hosted by Flying Circus.