Deja-dup error "volume doesn’t implement mount”

I’m running unstable and would like to use deja-dup (duplicity wrapper).

I’ve loaded the .config from my previous Arch installation that was fine for deja-dup all the time. However, now it says “volume doesn’t implement mount”.

Therefore, i added the following to my configuration.nix:

services.gvfs.enable = true; services.openssh.enable = true; services.duplicity.enable = true; services.duplicity.frequency = null; services.duplicity.targetUrl = "";

I also installed dbus eggdbus

Launching it in the terminal, the following error was displayed:

(org.gnome.DejaDup:169855): dconf-WARNING **: 19:10:46.228: failed to commit changes to dconf: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name ca.desrt.dconf was not provided by any .service files

Therefore i added programs.dconf.enable = true; which got rid of this error. However, in the UI of deja-dup it still says “volume doesn’t implement mount”.

I’m out of ideas regarding what additional services i have to enable in NixOS to make it work. Can you please tell me?

I would expect enabling gvfs to fix that. However the module adds an environment variable so you might need to re-log in into you your session for that to apply.

Thank you. After reboot/re-login it is working now. Didn’t think of that, sorry.