"Dirt Rally" quit with error 127

[eyome@nixos:~]$ nvidia-offload steam
steam.sh[38515]: Running Steam on nixos 23.11 64-bit
steam.sh[38515]: STEAM_RUNTIME is enabled automatically
setup.sh[38593]: Steam runtime environment up-to-date!
run.sh[38605]: Warning: An unexpected error occurred while executing "/sbin/ldconfig -XNv", the exit status was 127
steam.sh[38515]: Steam client's requirements are satisfied
[2023-06-28 01:43:06] Startup - updater built May 30 2023 20:40:12
[2023-06-28 01:43:06] Startup - Steam Client launched with: '/home/eyome/.local/share/Steam/ubuntu12_32/steam'
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38630)
Looks like steam didn't shutdown cleanly, scheduling immediate update check
[2023-06-28 01:43:06] Loading cached metrics from disk (/home/eyome/.local/share/Steam/package/steam_client_metrics.bin)
[2023-06-28 01:43:06] Using the following download hosts for Public, Realm steamglobal
[2023-06-28 01:43:06] 1. https://client-update.akamai.steamstatic.com, /, Realm 'steamglobal', weight was 1000, source = 'update_hosts_cached.vdf'
[2023-06-28 01:43:06] 2. https://cdn.cloudflare.steamstatic.com, /client/, Realm 'steamglobal', weight was 1, source = 'update_hosts_cached.vdf'
[2023-06-28 01:43:06] 3. http://media.steampowered.com, /client/, Realm 'steamglobal', weight was 1, source = 'baked in'
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38636)
[2023-06-28 01:43:06] Checking for update on startup
[2023-06-28 01:43:06] Checking for available updates...
[2023-06-28 01:43:06] Downloading manifest: https://client-update.akamai.steamstatic.com/steam_client_ubuntu12
[2023-06-28 01:43:06] Manifest download: send request
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38637)
[2023-06-28 01:43:07] Manifest download: waiting for download to finish
[2023-06-28 01:43:07] Manifest download: finished
[2023-06-28 01:43:07] Downloaded new manifest: /steam_client_ubuntu12 version 1687386907, installed version 1685488080, existing pending version 0
[2023-06-28 01:43:07] Download complete.
[2023-06-28 01:43:07] uninstalled manifest found in /home/eyome/.local/share/Steam/package/steam_client_ubuntu12 (1).
[2023-06-28 01:43:07] Found pending update
[2023-06-28 01:43:07] Installing update...
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38638)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38639)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38640)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38641)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38642)
[2023-06-28 01:43:07] Extracting package...
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38643)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38644)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38645)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38646)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38647)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38648)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38649)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38650)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38651)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38652)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38654)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38655)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38656)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38657)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38658)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38659)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38660)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38661)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38662)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38663)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38664)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38665)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38666)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38667)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38668)
[2023-06-28 01:43:16] Installing update...
[2023-06-28 01:43:17] Cleaning up...
[2023-06-28 01:43:17] Update complete, launching Steam...
[2023-06-28 01:43:17] Shutdown
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38672)
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(38673)
steam.sh[38515]: Restarting Steam by request...
steam.sh[38515]: Running Steam on nixos 23.11 64-bit
steam.sh[38515]: STEAM_RUNTIME has been set by the user to: /home/eyome/.local/share/Steam/ubuntu12_32/steam-runtime
setup.sh[38874]: Forced use of runtime version for 32-bit libgtk-x11-2.0.so.0
setup.sh[38874]: Forced use of runtime version for 32-bit libdbusmenu-glib.so.4
setup.sh[38874]: Forced use of runtime version for 32-bit libcurl.so.4
setup.sh[38874]: Forced use of runtime version for 32-bit libcurl-gnutls.so.4
setup.sh[38874]: Forced use of runtime version for 32-bit libdbusmenu-gtk.so.4
setup.sh[38874]: Forced use of runtime version for 64-bit libcurl.so.4
setup.sh[38874]: Forced use of runtime version for 64-bit libcurl-gnutls.so.4
run.sh[39464]: Warning: An unexpected error occurred while executing "/sbin/ldconfig -XNv", the exit status was 127
steam.sh[38515]: Steam client's requirements are satisfied
[2023-06-28 01:43:24] Startup - updater built Jun 21 2023 21:17:38
[2023-06-28 01:43:24] Startup - Steam Client launched with: '/home/eyome/.local/share/Steam/ubuntu12_32/steam'
06/28 01:43:24 Init: Installing breakpad exception handler for appid(steam)/version(1687386907)/tid(39487)
[2023-06-28 01:43:24] Loading cached metrics from disk (/home/eyome/.local/share/Steam/package/steam_client_metrics.bin)
[2023-06-28 01:43:24] Using the following download hosts for Public, Realm steamglobal
[2023-06-28 01:43:24] 1. https://client-update.akamai.steamstatic.com, /, Realm 'steamglobal', weight was 1000, source = 'update_hosts_cached.vdf'
[2023-06-28 01:43:24] 2. https://cdn.cloudflare.steamstatic.com, /client/, Realm 'steamglobal', weight was 1, source = 'update_hosts_cached.vdf'
[2023-06-28 01:43:24] 3. http://media.steampowered.com, /client/, Realm 'steamglobal', weight was 1, source = 'baked in'
[2023-06-28 01:43:24] Verifying installation...
[2023-06-28 01:43:24] Verification complete

(process:39487): GLib-GObject-CRITICAL **: 01:43:24.377: g_object_ref: assertion 'G_IS_OBJECT (object)' failed

(process:39487): GLib-GObject-CRITICAL **: 01:43:24.377: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
/nix/store/p7njqfc1l00hxvm5zvjshahxqca5k9vm-dconf-0.40.0-lib/lib/gio/modules/libdconfsettings.so: wrong ELF class: ELFCLASS64
Failed to load module: /nix/store/p7njqfc1l00hxvm5zvjshahxqca5k9vm-dconf-0.40.0-lib/lib/gio/modules/libdconfsettings.so
/nix/store/mbh4j65zfm2py09y6k20qsgwjvy6k8xh-gvfs-1.50.4/lib/gio/modules/libgvfsdbus.so: wrong ELF class: ELFCLASS64
Failed to load module: /nix/store/mbh4j65zfm2py09y6k20qsgwjvy6k8xh-gvfs-1.50.4/lib/gio/modules/libgvfsdbus.so
XRRGetOutputInfo Workaround: initialized with override: 0 real: 0xf04906b0
XRRGetCrtcInfo Workaround: initialized with override: 0 real: 0xf048ef80
GetWin32Stats: display was not open yet, good
Loaded SDL version 3.0.0-1782-g214d5daa3
GetWin32Stats: display was not open yet, good
steamwebhelper.sh[39504]: Runtime for steamwebhelper: defaulting to /home/eyome/.local/share/Steam/ubuntu12_64/steam-runtime-heavy
steamwebhelper.sh[39504]: glibc >= 2.34, partially disabling sandbox until CEF supports clone3()
CAppInfoCacheReadFromDiskThread took 29 milliseconds to initialize
Failed to init SteamVR because it isn't installed

(steam:39487): Gtk-WARNING **: 01:43:29.681: gtk_disable_setlocale() must be called before gtk_init()
local (potentially out of sync) copy of roaming config loaded - 231 bytes.
BRefreshApplicationsInLibrary 1: 1ms
roaming config store loaded successfully - 231 bytes.
migrating temporary roaming config store

(steam:39487): GLib-GObject-CRITICAL **: 01:43:31.848: g_object_ref: assertion 'G_IS_OBJECT (object)' failed

(steam:39487): GLib-GObject-CRITICAL **: 01:43:31.848: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
System startup time: 7.84 seconds
BuildCompleteAppOverviewChange: 233 apps

(steam:39487): Gtk-WARNING **: 01:43:33.001: gtk_disable_setlocale() must be called before gtk_init()
RegisterForAppOverview 1: 76ms
RegisterForAppOverview 2: 76ms
ExecCommandLine: "'/home/eyome/.local/share/Steam/ubuntu12_32/steam'"

(steam:39487): GLib-GObject-CRITICAL **: 01:43:34.431: g_object_ref: assertion 'G_IS_OBJECT (object)' failed

(steam:39487): GLib-GObject-CRITICAL **: 01:43:34.431: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

(steam:39487): Gtk-WARNING **: 01:43:50.816: gtk_disable_setlocale() must be called before gtk_init()
GameAction [AppID 310560, ActionID 1] : LaunchApp changed task to ProcessingInstallScript with ""
GameAction [AppID 310560, ActionID 1] : LaunchApp changed task to SynchronizingCloud with ""

(steam:39487): GLib-GObject-CRITICAL **: 01:44:01.275: g_object_ref: assertion 'G_IS_OBJECT (object)' failed

(steam:39487): GLib-GObject-CRITICAL **: 01:44:01.275: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
GameAction [AppID 310560, ActionID 1] : LaunchApp changed task to SynchronizingControllerConfig with ""

(steam:39487): GLib-GObject-CRITICAL **: 01:44:01.813: g_object_ref: assertion 'G_IS_OBJECT (object)' failed

(steam:39487): GLib-GObject-CRITICAL **: 01:44:01.813: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
GameAction [AppID 310560, ActionID 1] : LaunchApp changed task to SiteLicenseSeatCheckout with ""
GameAction [AppID 310560, ActionID 1] : LaunchApp changed task to CreatingProcess with ""
GameAction [AppID 310560, ActionID 1] : LaunchApp waiting for user response to CreatingProcess ""
GameAction [AppID 310560, ActionID 1] : LaunchApp continues with user response "CreatingProcess"
/bin/sh\0-c\0/home/eyome/.local/share/Steam/ubuntu12_32/reaper SteamLaunch AppId=310560 -- /home/eyome/.local/share/Steam/ubuntu12_32/steam-launch-wrapper -- '/mnt/Jeux/Steam/steamapps/common/DiRT Rally/DirtRally.sh'\0
Game process added : AppID 310560 "/home/eyome/.local/share/Steam/ubuntu12_32/reaper SteamLaunch AppId=310560 -- /home/eyome/.local/share/Steam/ubuntu12_32/steam-launch-wrapper -- '/mnt/Jeux/Steam/steamapps/common/DiRT Rally/DirtRally.sh'", ProcID 39864, IP 0.0.0.0:0
chdir "/mnt/Jeux/Steam/steamapps/common/DiRT Rally"
ERROR: ld.so: object '/home/eyome/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/home/eyome/.local/share/Steam/ubuntu12_64/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object '/home/eyome/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/home/eyome/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
GameAction [AppID 310560, ActionID 1] : LaunchApp changed task to WaitingGameWindow with ""

(steam:39487): GLib-GObject-CRITICAL **: 01:44:02.085: g_object_ref: assertion 'G_IS_OBJECT (object)' failed

(steam:39487): GLib-GObject-CRITICAL **: 01:44:02.085: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
GameAction [AppID 310560, ActionID 1] : LaunchApp changed task to Completed with ""
ERROR: ld.so: object '/home/eyome/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/home/eyome/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
pid 39872 != 39869, skipping destruction (fork without exec?)
pid 39871 != 39869, skipping destruction (fork without exec?)
ERROR: ld.so: object '/home/eyome/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
=== ERROR - You're missing vital libraries to run DiRT Rally
=== Either use the steam runtime or install these using your package manager
ERROR: ld.so: object '/home/eyome/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
/mnt/Jeux/Steam/steamapps/common/DiRT Rally/bin/DirtRally: /home/eyome/.local/share/Steam/ubuntu12_32/steam-runtime/pinned_libs_64/libcurl.so.4: version `CURL_OPENSSL_4' not found (required by /mnt/Jeux/Steam/steamapps/common/DiRT Rally/bin/DirtRally)
	libSDL2-2.0.5.so => not found
	libSDL2_image-2.0.1.so => not found
	libcef.so => not found
	libpdf.so => not found
===
ERROR: ld.so: object '/home/eyome/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/home/eyome/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.

(steam:39487): GLib-GObject-CRITICAL **: 01:44:02.328: g_object_ref: assertion 'G_IS_OBJECT (object)' failed

(steam:39487): GLib-GObject-CRITICAL **: 01:44:02.328: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
ERROR: ld.so: object '/home/eyome/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
/mnt/Jeux/Steam/steamapps/common/DiRT Rally/bin/DirtRally: error while loading shared libraries: libSDL2-2.0.5.so: cannot open shared object file: No such file or directory
'DiRT Rally' quit with error code '127'.
If possible, launch Steam from command line to check the output when 'DiRT Rally' is run.
Then, contact support@feralinteractive.com with details of the output, as well as your Steam System Info.

It seems some dependancIes are missing, so I tried to find them on Nixos:

  users.users.eyome = {
    isNormalUser = true;
    description = "eyome";
    extraGroups = [ "networkmanager" "wheel" "scanners" "lp" ];
    packages = with pkgs; [
      amberol
      bottles
      curtail
      curl
      dino
      drawing
      dolphin-emu
      duckstation
      firefox
#      fragments
      fuse
      glxinfo
      gnomeExtensions.gsconnect
      gnomeExtensions.just-perfection
      gnome.gnome-boxes
      gnome-firmware
#      gnome-frog
      gnome.gnome-logs
      gnome.gnome-software
      gnome.gnome-tweaks
      heroic
      kodi
      libcef
      libreoffice-fresh
      mesa
      mesa-demos
#      mousai
      neofetch
      nix-diff
      nixos-option
#      nix-software-center
      noto-fonts-emoji
      ntfs3g
#      pcsx2
#      rustdesk
      sane-airscan
      SDL2
      SDL2_image
      shortwave
      steam
      ungoogled-chromium
      xemu
    ];
  };

But Dirt still asking a specific SDL2 version for example.
I am using Nixos unstable.
Is there a way to force Dirt to use the current versions of softwares for SDL2 or SDL2_image for example?
How to solve this dependancies issues?
Thank you.

Hi,

I found by accident I didn’t activate the Steam Play compatibility tool.

Now, I got this error:

[eyome@nixos:~]$ nvidia-offload steam
steam.sh[3746]: Running Steam on nixos 23.11 64-bit
steam.sh[3746]: STEAM_RUNTIME is enabled automatically
setup.sh[3824]: Steam runtime environment up-to-date!
run.sh[3836]: Warning: An unexpected error occurred while executing "/sbin/ldconfig -XNv", the exit status was 127
steam.sh[3746]: Steam client's requirements are satisfied
[2023-08-10 17:48:14] Startup - updater built Jul 28 2023 18:44:09
[2023-08-10 17:48:14] Startup - Steam Client launched with: '/home/eyome/.local/share/Steam/ubuntu12_32/steam'
08/10 17:48:14 Init: Installing breakpad exception handler for appid(steam)/version(1690583737)/tid(3859)
Looks like steam didn't shutdown cleanly, scheduling immediate update check
[2023-08-10 17:48:14] Loading cached metrics from disk (/home/eyome/.local/share/Steam/package/steam_client_metrics.bin)
[2023-08-10 17:48:14] Using the following download hosts for Public, Realm steamglobal
[2023-08-10 17:48:14] 1. https://client-update.akamai.steamstatic.com, /, Realm 'steamglobal', weight was 1000, source = 'update_hosts_cached.vdf'
[2023-08-10 17:48:14] 2. https://cdn.cloudflare.steamstatic.com, /client/, Realm 'steamglobal', weight was 1, source = 'update_hosts_cached.vdf'
[2023-08-10 17:48:14] 3. https://cdn.steamstatic.com, /client/, Realm 'steamglobal', weight was 1, source = 'baked in'
[2023-08-10 17:48:14] Checking for update on startup
[2023-08-10 17:48:14] Checking for available updates...
[2023-08-10 17:48:14] Downloading manifest: https://client-update.akamai.steamstatic.com/steam_client_ubuntu12
[2023-08-10 17:48:14] Manifest download: send request
[2023-08-10 17:48:15] Manifest download: waiting for download to finish
[2023-08-10 17:48:16] Manifest download: finished
[2023-08-10 17:48:16] Download skipped: /steam_client_ubuntu12 version 1690583737, installed version 1690583737, existing pending version 0
[2023-08-10 17:48:16] Nothing to do
[2023-08-10 17:48:16] Verifying installation...
[2023-08-10 17:48:16] Performing checksum verification of executable files
[2023-08-10 17:48:17] Verification complete
/nix/store/ysj1wc9q08gfrdk9ylncdx3r986vfqkj-dconf-0.40.0-lib/lib/gio/modules/libdconfsettings.so: wrong ELF class: ELFCLASS64
Failed to load module: /nix/store/ysj1wc9q08gfrdk9ylncdx3r986vfqkj-dconf-0.40.0-lib/lib/gio/modules/libdconfsettings.so
/nix/store/k10b8lrhsslsimd1p1ldf8f9vyhynch0-gvfs-1.50.6/lib/gio/modules/libgvfsdbus.so: wrong ELF class: ELFCLASS64
Failed to load module: /nix/store/k10b8lrhsslsimd1p1ldf8f9vyhynch0-gvfs-1.50.6/lib/gio/modules/libgvfsdbus.so
XRRGetOutputInfo Workaround: initialized with override: 0 real: 0xf0a307b0
XRRGetCrtcInfo Workaround: initialized with override: 0 real: 0xf0a2efa0
GetWin32Stats: display was not open yet, good
GetWin32Stats: display was not open yet, good
steamwebhelper.sh[3875]: Runtime for steamwebhelper: defaulting to /home/eyome/.local/share/Steam/ubuntu12_64/steam-runtime-heavy
steamwebhelper.sh[3875]: glibc >= 2.34, partially disabling sandbox until CEF supports clone3()
CAppInfoCacheReadFromDiskThread took 72 milliseconds to initialize
BRefreshApplicationsInLibrary 1: 1ms
BuildCompleteAppOverviewChange: 234 apps
RegisterForAppOverview 1: 54ms
RegisterForAppOverview 2: 54ms
pressure-vessel-wrap[4098]: W: "/run/current-system/sw/bin/getent" is unlikely to appear in "/run/host"
pressure-vessel-wrap[4098]: W: Found more than one possible libdrm data directory from provider
/nix/store/ysj1wc9q08gfrdk9ylncdx3r986vfqkj-dconf-0.40.0-lib/lib/gio/modules/libdconfsettings.so: undefined symbol: g_hash_table_get_keys_as_array
Failed to load module: /nix/store/ysj1wc9q08gfrdk9ylncdx3r986vfqkj-dconf-0.40.0-lib/lib/gio/modules/libdconfsettings.so
/nix/store/k10b8lrhsslsimd1p1ldf8f9vyhynch0-gvfs-1.50.6/lib/gvfs/libgvfscommon.so: undefined symbol: g_task_set_source_tag
Failed to load module: /nix/store/k10b8lrhsslsimd1p1ldf8f9vyhynch0-gvfs-1.50.6/lib/gio/modules/libgvfsdbus.so
/nix/store/k10b8lrhsslsimd1p1ldf8f9vyhynch0-gvfs-1.50.6/lib/gvfs/libgvfscommon.so: undefined symbol: g_task_set_source_tag
Failed to load module: /nix/store/k10b8lrhsslsimd1p1ldf8f9vyhynch0-gvfs-1.50.6/lib/gio/modules/libgioremote-volume-monitor.so
/nix/store/x56c85zcq6xlnvhwc2ksk4izma5bi3zy-glib-networking-2.76.1/lib/gio/modules/libgiolibproxy.so: undefined symbol: g_task_get_source_tag
Failed to load module: /nix/store/x56c85zcq6xlnvhwc2ksk4izma5bi3zy-glib-networking-2.76.1/lib/gio/modules/libgiolibproxy.so
/nix/store/x56c85zcq6xlnvhwc2ksk4izma5bi3zy-glib-networking-2.76.1/lib/gio/modules/libgiognomeproxy.so: undefined symbol: g_task_get_source_tag
Failed to load module: /nix/store/x56c85zcq6xlnvhwc2ksk4izma5bi3zy-glib-networking-2.76.1/lib/gio/modules/libgiognomeproxy.so
/nix/store/x56c85zcq6xlnvhwc2ksk4izma5bi3zy-glib-networking-2.76.1/lib/gio/modules/libgiognutls.so: undefined symbol: g_byte_array_steal
Failed to load module: /nix/store/x56c85zcq6xlnvhwc2ksk4izma5bi3zy-glib-networking-2.76.1/lib/gio/modules/libgiognutls.so
fsync: up and running.
wine: RLIMIT_NICE is <= 20, unable to use setpriority safely
[2023-08-10 17:50:21] Background update loop checking for update. . .
[2023-08-10 17:50:21] Checking for available updates...
[2023-08-10 17:50:21] Downloading manifest: https://client-update.akamai.steamstatic.com/steam_client_ubuntu12?t=4170683472
[2023-08-10 17:50:21] Manifest download: send request
[2023-08-10 17:50:21] Manifest download: waiting for download to finish
[2023-08-10 17:50:22] Manifest download: finished
[2023-08-10 17:50:22] Download skipped by HTTP 304 Not Modified
[2023-08-10 17:50:22] Nothing to do

As it says, nothing happens.

I don’t get why I have these errors as dconf, glib-networking and gvfs are installed:

  # Define a user account. Don't forget to set a password with ‘passwd’.
  users.users.eyome = {
    isNormalUser = true;
    description = "eyome";
    extraGroups = [ "networkmanager" "wheel" "scanners" "lp" ];
    packages = with pkgs; [
      amberol
      bottles
      celluloid
      curtail
      curl
      dino
      drawing
      dolphin-emu
      duckstation
      firefox
#      fragments
      fuse
      glxinfo
      glib-networking
      gnomeExtensions.gsconnect
      gnomeExtensions.just-perfection
      gnome.gnome-boxes
      gnome-firmware
#      gnome-frog
      gnome.gnome-logs
      gnome.gnome-software

Therefore, as I use Gnome, should I add dconf, glib-networking and gvfs in my configuration.nix? Aren’t they Gnome dependancies?
Thank you.

https://www.protondb.com/app/310560

On PC section, Dirt should work natively…

But, 6 days ago:

Tinker Steps:
Custom Proton: GE
Native version doesn’t work, with error 127. Have to switch to the feral beta with code feraldirtsupport, install libxcrypt-compat, and run with Proton GE

I activated the Feral beta with the code, but it still doesn’t work.
(I didn’t find libxcrypt-compat on Nixos repo by the way).

1 Like