Discord not starting: sys_waitpid() for gzip process failed

My Discord won’t start anymore. I’m new to NixOs, so not sure if this is a bug or I did something stupid, therefore asking here first before opening a bug ticket on nixpkgs. :sweat_smile: Output:

[user@system:~]$ discord
Discord 0.0.20
Starting app.
Removing old directory  0.0.19
Starting updater.
[Modules] Modules initializing
[Modules] Distribution: remote
[Modules] Host updates: enabled
[Modules] Module updates: enabled
[Modules] Module install path: /home/katexochen/.config/discord/0.0.20/modules
[Modules] Module installed file path: /home/katexochen/.config/discord/0.0.20/modules/installed.json
[Modules] Module download path: /home/katexochen/.config/discord/0.0.20/modules/pending
Cannot exec gzip.
sys_waitpid() for gzip process failed.

Unexpected crash report id length
Failed to get crash dump id.
Report Id: 

I installed Discord via home-manager:

 home-manager.users.katexochen = {pkgs, ...}: {
    home.stateVersion = "22.05";
    home.enableNixpkgsReleaseCheck = true;

    home.sessionVariables = {
      XDG_CURRENT_DESKTOP = "sway";

    home.packages = with pkgs; [


[user@system:~]$ nix-shell -p nix-info --run "nix-info -m"
this path will be fetched (0.06 MiB download, 0.30 MiB unpacked):
copying path '/nix/store/51zlypw5hnf1b9lg56vlgfwla5zq1s9w-bash-interactive-5.1-p16-dev' from 'https://cache.nixos.org'...
 - system: `"x86_64-linux"`
 - host os: `Linux 5.18.19, NixOS, 22.05 (Quokka), 22.05.3201.bcc68429a50`
 - multi-user?: `yes`
 - sandbox: `yes`
 - version: `nix-env (Nix) 2.8.1`
 - channels(katexochen): `"home-manager-22.05.tar.gz"`
 - channels(root): `"home-manager-22.05.tar.gz, nixos-22.05"`
 - nixpkgs: `/nix/var/nix/profiles/per-user/root/channels/nixos`

If I’m reading that output correctly, you tried to use discord’s self-update mechanism. That won’t work. You need to update discord through nix, and the new version probably isn’t in nixpkgs yet. Discord doesn’t give us a single second of advance warning before requiring the new version… it sucks, but that’s life.

I just run discord from my browser with --app= instead, to avoid the update problem. It also has the nice side benefit of sandboxing the app a lot more.

See Discord - NixOS Wiki for other alternatives (including how to force discord to start even with an old version).

1 Like

Thanks, great tip to use Chromium’s --app= option, this works well.

I’ve tried the "SKIP_HOST_UPDATE": true option in the config file of Discord, that didn’t help. I also didn’t tried to update Discord, beside running nixos-rebuild --upgrade.

Guess I must have misunderstood that part of the situation, then. Perhaps the references to updating are about migrating saved data of some kind?