Displaying UTF8 characters is not supported on busybox shell. How to enable it?

I’ve found that I cant display non-ASCII characters on busybox shell (which I installed to my docker image with dockerTools.streamLayeredImage). I suspect that UTF-8 support is not enabled for busybox build available in nixpkgs. Probably to reduce the binary size for use cases like docker images?

Then, How to build busybox from source, and enable UTF-8 support for busybox, then?
I don’t want to switch to other shells (such as bash) just to avoid this issue.
I could pass some additional build options to busybox… but which one?
Should I just copy options from other OSSes? I don’t know how these options work.