Displays not working correctly via Thunderbold dock


I am trying to drive two 1440p displays using DisplayPort via a Dell WD19TB dock (the dock is enrolled). The problem is, I can’t get Hyprland to drive both displays in 1440p. After booting both displays default to 1080p. I think this is the kernel mode setting. After Hyprland takes over I am unable to switch them to 1440p. If I reconnect the dock, the first display starts working at 1440p but the second display can not be driven.

In both cases the output of wlr-randr shows both displays, it just refuses to apply any configuration. The same goes for wdisplays.

I have tried multiple combinations of setting and blacklisting kernel modules. Especially the amdgpu module to force the system to use i965. I have also tried older kernels . I have tried with and without Plymouth, systemd in initrd and nomodeset. All to no avail.

Now if I boot the NixOS live ISO with Gnome, Gnome is able to drive both displays at 1440p out of the box. If i run lsmod in the live session the amdgpu module is loaded.

My previous os on this machine was Fedora with home-manager on top. I was able to run the same Hyprland configuration via home-manager on top of Fedora. All this leads me to believe I am missing something in the initrd/kernel stage but I could be totally off.

Any pointers towards what steps I can try to get this to work are greatly appreciated.