Emacs doesn't install with Info doc files?

I think Emacs is usually supposed to come with the Info documentation files that you can view in Info mode from within the program, but these seem to be missing for some reason. I still get Info files for packages installed alongside Emacs (using Nix), but not Emacs itself. Any idea what I should be overriding in the package to get this? Thanks.

Actually taking a closer look, it seems the files are installed somewhere because you can get to the Emacs manual with M-x info-emacs-manual, but it is missing from the top-level Info directory, along with related docs like the Elisp programming reference. Does anyone know how to get this stuff to show up in Info top-level view like it does in other distros?

Do you mean C-h i is empty? That it doesn’t display this?

Hi, not exactly. That is the Emacs manual which I can still get to from C-h r. I figured out that this is actually still installed (but not in the expected way) after I made the original post. Sorry for the confusion. I’m talking about the Info Directory node (press d in an Info mode buffer) which lists all the Info files installed on your system. I’m pretty sure on another distro this listed the Emacs and Elisp docs, but now my “Emacs” section of the directory only has Info pages for packages I’ve installed, but not Emacs itself, if that makes sense.

Here is an example I’ve found of someone else’s Emacs:

Under the Emacs section, mine is missing the Elisp, Emacs Lisp Intro, Emacs, and Emacs FAQ docs, and only has the specific package docs (for example, something like AUCTeX in this picture).

Ah might have might have clicked on a link. C-h i takes me to the Info Directory and the docs for Emacs are present.

I installed Emacs through home-manager on my systems.

I checked the source for the home-manager config but it doesn’t look like the include anything special.