Enable natural scrolling configuration.nix

#1

I have been trying to get natural scrolling to work but the services.xserver.libinput.naturalScrolling seems to have no effect.

How does one enable natural scrolling?

0 Likes

#2

Unfortunately not all desktop environments will pick this setting up. In particular in Gnome you might need to set this manually:

dconf write /org/gnome/desktop/peripherals/touchpad/natural-scroll true
dconf write /org/gnome/desktop/peripherals/mouse/natural-scroll true
0 Likes