Enable plasma5 and gnome3 with Wifi

#1

How can I enable both DEs, plasma5 and gnome3 when I am using wifi?
Gnome seems to enforce networking.networkmanager.enable = true; whereas kde needs networking.wireless.enable = true;. Theses settings are not compatible and will not allow me to build the system.

#2

I don’t see networking.wireless.enable in the plasma5 module so I don’t think the problem is there.

Is it by chance a message like?

You can not use networking.networkmanager with networking.wireless

#3

Yes, that is the message. If I don’t set networking.wireless.enable, I have no wifi using kde only.

#4

So networking.networkmanager.enable defaults to true for the gnome3 module.

So you just need to disable it

networking.networkmanager.enable = false;