Enabling/fixing touch gestures in Nix 24.05

BLOT: Can’t switch applications or workspaces with 3-finger swipe after upgrading to 24.05.

I just upgraded NixOS from 23.11 to 24.05 with a fairly standard config, and it looks like my Gnome (v46, x11) gestures have stopped working. Whereas I could previously swipe up (3 fingers) to switch applications or swipe left/right (also 3 fingers) to switch workspaces, it seems the only gesture that works now is two-finger scrolling. Is this a configuration issue or something else, and is there a workaround to re-enable rich gestures?

1 Like

Did you use any extensions to make it work before? Because I’ve heard that multi-gesture touchpad was limited under X11.

One way to quickly test if it’s an X11 issue is to try this with Wayland and see if it works there or not out of the box.

If not, maybe you need to set one (or both) of these:

    services.libinput.enable = true;

    # multi-touch gesture recognizer
    services.touchegg.enable = true;

if it still doesn’t work, you might want to try an extension such as gnomeExtensions.x11-gestures (which depends on the touchegg service)

Thanks for the reply! I was up and down the extensions list yesterday trying to figure out if anything had changed, but when I rebooted this afternoon it…started working. Definitely didn’t after two reboots yesterday, but it seems functional now. Not the most satisfying answer, but I’ll take it.

1 Like