Error running update when adding vim plugins


#1

Been following the add plugins section of this documentation to add vim plugins:

https://nixos.wiki/wiki/Vim

When I run ./update.py I get this error:

error: attribute 'rev' missing, at (string):8:13
(use '--show-trace' to show detailed location information)
Traceback (most recent call last):
  File "./update.py", line 353, in <module>
    main()
  File "./update.py", line 334, in main
    current_plugins = get_current_plugins()
  File "./update.py", line 144, in get_current_plugins
    out = subprocess.check_output(["nix", "eval", "--json", GET_PLUGINS])
  File "/nix/store/d74rl714a32wbv5i5j5qblcl169k1vs4-python3-3.7.2/lib/python3.7/subprocess.py", line 395, in check_output
    **kwargs).stdout
  File "/nix/store/d74rl714a32wbv5i5j5qblcl169k1vs4-python3-3.7.2/lib/python3.7/subprocess.py", line 487, in run
    output=stdout, stderr=stderr)
subprocess.CalledProcessError: Command '['nix', 'eval', '--json', '(with import <localpkgs> {};\nlet\n  hasChecksum = value: lib.isAttrs value && lib.hasAttrByPath ["src" "outputHash"] value;\n  getChecksum = name: value:\n    if hasChecksum value then {\n      submodules = value.src.fetchSubmodules or false;\n      sha256 = value.src.outputHash;\n      rev = value.src.rev;\n    } else null;\n  checksums = lib.mapAttrs getChecksum vimPlugins;\nin lib.filterAttrs (n: v: v != null) checksums)']' returned non-zero exit status 1.

Any ideas what could be wrong? Thanks for help.


#2

I reported it yesterday and a fix is avaiable here https://github.com/NixOS/nixpkgs/pull/56191