Errors while installing firefox using home-manager in macos

I tried to install firefox using home-manager in macos(Catalina) and it always fails. Also vlc, vscode also fails to install.
this is the installation error for firefox

Package ‘Firefox-77.0.1’ in /nix/store/8pb00wg955j5ls3l1x3dgin15x19wxw3-nixpkgs-20.09pre234236.c87c474b17a/nixpkgs/pkgs/applications/networking/browsers/firefox/wrapper.nix:173 is not supported on ‘x86_64-darwin’, refusing to evaluate.

Has anyone successfully installed firefox in macos using home-manager.
Please help me.

Last time I checked it looked like building Firefox from source on Darwin is some kind of witchcraft. There was even a Mozilla repository on GitHub where people got together, tried building it with nix and still failed on Darwin. I think the easiest thing at the moment is declaring a package which just downloads the binary as described here.

Side note: All those discussions around how hard it is to install nix on Darwin in the first place are moot if you cannot get most popular programs to run at all once you have it…