External hard drive read only

I don’t have problem with my usb stick, but my external hdd can’t be used to backup my home. rsync tells me the disk is read only then I tried to copy something manually to confirm the problem, so it is not an rsync problem.
I booted a live iso of Axyl distro to make my backup on this device and rsync worked fine.
The problem is probably obvious for a non beginner.

How did you mount the drive? If you just connected it and it mounted automatically, what desktop environment do you use?

1 Like

I plugged the drive then I entered the command “sudo mount /dev/sdb1 /run/mount” .

I also tried to mount with “sudo mount /dev/sdb1 /run/media/username” with the same result.

New info: the usb stick gaves the same result than the external hdd. The initial post is wrong because the stick was mounted automatically by spacefm file manager, so i believed my hdd had a problem.
So spacefm know how to mount my drives.
My pseudo-DE is bspwm (thats why I choosed Axyl distro to make a test). Sorry for the english.

What filesystem are the HDD and the USB stick?

Unless they are linux permission aware, you mounted them owned by root, with permissions that usually make it hard to write to the disk even for root.

Though as you seem to be using udisk2 already, just stick to SpaceFM to mount the drive or use udisksctl to mount and unmount removable media

Ok, I tried another usb stick and it was mounted without the write limitation, as I wanted.
Then I reinitialized the problematic usb stick using Gparted, (partition table then ext4 partition) and this device is now normal !
There is still my external hdd, but there is a bunch of GB inside.
Axyl distro was able to mount this device normally, so I suspect something in the OS has to be reinitialized.
Maybe fstab ? I have to search info about filesytem options.

What FS is it?

Why do you mount it using sudo rather than a userspace mount?

I want to backup my home in the external hdd, the fs is ntfs.

NTFS does not know about Linux permissions, you will loose important information in that process.

Also, for being able to mount NTFS writable you’ll need driver support.

Last but not least as NTFS is not aware of Linux permissions, it will usually mounted in a way that all files appear owned by root and are usually 644 for files and 755 for folders. If you want anything else, you need to pass appropriate options when mounting.

A Userlevel mounttool like udisksctl makes that a lot easier, it will mount in a way that your user has appropriate permissions on the mounted drive.

ntfs-3g is installed. Help on the web doesn’t provides particular advices, just mount if you have ntfs-3g.

How have you installed it? And have you checked whether or not udisksctl works?

It is already installed. But I tried something in the meanwile and It seems the problem is solved.
I added the option boot.supportedFilesystems = ["ntfs"] to configuration.nix. Thank you Nobbz.