Framework laptop won't boot after update

Since I updated NixOS on Nov 3, I am no longer able to boot into the new configuration. The laptop just hangs at NixOS Stage 1. My machine is an i5 Framework.

Any thoughts about what might be causing this or how to diagnose?

1 Like


So, it appears that although the only thing I see is “NixOS Stage 1”, I decided to try entering the passphrase to unlock my hd, and lo and behold it worked.

Apparently. it is booting to the point where it asks me for my passphrase, but it just is not displaying the prompt.

Any ideas?

1 Like

Do you use plymouth?

No I don’t use plymouth.

Hmmmm, are you on unstable? I’ve noticed a few boot issues with 6.6.0 kernel and unstable. 6.5.9 works fine

Yes, I’m on unstable. I also just noticed that although I found a way to boot, my networking is misbehaving. I can’t mount the samba shares from my nas anymore.

on my laptop I ran into this: i915 doesn't work in Linux 6.6.0 · Issue #265187 · NixOS/nixpkgs · GitHub and the fix has been merged or backported to 23.05. Folks also reported being able to type in their passwords and get in although it appears as if system is hanging. Something about the frame buffer. Unstable is still a few days behind? nixos-unstable release nixos-23.11pre543390.fa804edfb786 I don’t know what’s up with AMD desktop but I ran into boot hanging issues there as well. I just rolled back to 6.5.9 and all is fine. Also pointed my nixpkgs to the master branch (bad idea? maybe…) and did a rebuild for kicks and 6.6.0 booted fine on my laptop.

1 Like

back on unstable with 6.6.0 kernel and things seem to work across the board :slight_smile:

Yes, the frame buffer issue at boot is fixed, but I am still having problems with mounting my NAS shares.

I get:

❯ sudo mount /mnt/media/
Couldn't chdir to /mnt/media: No such device

And I’m assuming /mnt/media already exists? Perhaps permissions changed somehow? Sorry I can’t be more helpful.

Thanks for your reply. Yes, that directory exists, but I also get this message when trying to ls:

❯ ls /mnt/media
lsd: /mnt/media: No such device (os error 19).

If I boot back into kernel 6.5.9, everything works as expected.

I mount this directory automatically using:

 fileSystems."/mnt/media" = {
    device = "//nas/media";
    fsType = "cifs";
    options = let
      automount_opts = "x-systemd.automount,noauto,x-systemd.idle-timeout=60,x-systemd.device-timeout=5s,x-systemd.mount-timeout=5s";
    in ["${automount_opts},credentials=/home/user/smb-secrets,uid=1000"];

hmmm have a look at this Arch Linux ARM • View topic - mount.cifs error 19 - not saying it’s your issue but perhaps there’s something to be done with those automount options…

I am going to start a new thread about my mount issue, now that the i915 framebuffer issue has been resolved.