FZF keybinding getting erased by oh-my-zsh

I have been trying to get oh-my-zsh to be installed on my OS, and one of FZF’s keybinding (CTRL-R for history) is erased when trying to source /etc/zshrc.
Here is the configuration I’ve used with only the related stuff left.
I am on unstable with a channel recently updated.

environment.systemPackages = with pkgs; [ fzf ];
programs.zsh = {
  enable = true;
  interactiveShellInit = ''
export FZF_BASE=$(fzf-share)
source "$(fzf-share)/completion.zsh"
source "$(fzf-share)/key-bindings.zsh"
  ohMyZsh = {
    enable = true;
    plugins = [ "fzf" ];

I have based what I’ve written on fzf’s wiki page and zsh’s options.

I have noticed that manually sourcing the key-bindings.zsh file restore the key-binding, and sourcing the oh-my-zsh.zsh file erases it.

What should I do to fix this key-binding? I have tried to modify the oh-my-zsh script file but I am not that comfortable with it.

1 Like