Graphics driver Nvidia

I have AmongUs on steam and it worked previously. Then I wrongly installed an amd driver for my graphics card. Well I have a nvidia card… So I removed the drivers again and now Among us doesn’t start and gives this error.

Failed to initialize graphics.
Make sure you have DirectX 11 installed, have up to date
drivers for your graphics card and have not disabled
3D acceleration in display settings.
InitializeEngineGraphics failed

my nixos config should be standard for nvidia now.

  hardware = {
    opengl.driSupport32Bit = true;
    opengl.enable = true;
    opengl.extraPackages32 = with pkgs.pkgsi686Linux; [ libva ];
    opengl.setLdLibraryPath = true;
  environment.systemPackages = with pkgs; [

I installed loader and validation layers and hoped they would help, but I think I won’t need them.
Has anybody an idea how I can revert my mistake with the amd driver?

I also tried to start bombtag and the console which started steam stated. I think that is the same issue.
Other games like cs don’t have that issue

Player data archive not found at `Z:/mnt/sdd2/SteamLibrary/steamapps/common/BombTag/BombTag_Data/data.unity3d`, using local filesystemThe NVIDIA driver was unable to open ''.  This library is required at run time.

Silly question, but did you reboot?

Also, I have the following line on my configuration.nix

services.xserver.videoDrivers = ["nvidia"];

As far as I know, this is necessary for the proprietary nvidia drivers. If you want the open source drivers, shouldn’t you have xf86-video-nouveau somewhere as well?

Yes i rebooted and now i installed xf86-video-nouveau and rebooted again didn’t change the problem.