Gthumb startup error

Gthumb doesn’t seem to start in NixOS, but I only get this warning:
(gthumb:3808): Gtk-WARNING **: 09:21:52.960: Unknown key Settings in ~/.config/gtk-3.0/settings.ini

Here’s my settings.ini:

[Settings]
Settings=gtk-application-prefer-dark-theme=1
gtk-cursor-theme-name=Bibata-Modern-Ice

gtk-cursor-theme-name=Bibata-Modern-Ice
gtk-font-name=Code New Roman 11
gtk-icon-theme-name=Papirus-Dark
gtk-theme-name=Arc-Dark

What am I doing wrong?

gtk-cursor-theme-name is set twice to Bibata-Modern-Ice, I am guessing that’s the problem.

That was a good hunch, but I removed one of the gtk-cursor-theme-name entries and I get the same error.

The warning is from Settings=gtk-application-prefer-dark-theme=1, it should be gtk-application-prefer-dark-theme=1 but that should be unrelated.

Do you see anything in system journal?

1 Like

@jtojnar thanks for the help. That did the trick. Now I no longer get the warning message, but the program still doesn’t open up. I confirmed that gthumb is running since it’s listed in htop.

journalctl -p 3 -xb gives me:

Jun 30 20:54:27 nixos greetd[1884]: gkr-pam: unable to locate daemon control file
Jun 30 20:54:33 nixos pulseaudio[2170]: Get() failed: org.freedesktop.DBus.Error.Servic>
Jun 30 20:58:02 nixos kernel: ERROR @wl_notify_scan_status :
Jun 30 20:58:55 nixos kernel: ERROR @wl_notify_scan_status :

I don’t see anything related to gthumb though. Any ideas?