Has anyone got playonlinux working on 19.03?

Running “nix-env -iA nixos.playonlinux” fails with:

build flags: SHELL=/nix/store/cinw572b38aln37glr0zb8lxwrgaffl4-bash-4.4-p23/bin/bash
gcc -O2 ./src/check_direct_rendering.c -o ./bin/playonlinux-check_dd -lGL -lX11
./src/check_direct_rendering.c:31:10: fatal error: X11/Xlib.h: No such file or directory
 #include <X11/Xlib.h>
compilation terminated.
make: *** [Makefile:48: build] Error 1
builder for '/nix/store/dwjqifw27h4byqw6vkz94xsrsxzddnz6-playonlinux-4.3.4.drv' failed with exit code 2
cannot build derivation '/nix/store/bn45qnhnvlhdq7ywbfvg6w8f3rcjd26s-system-path.drv': 1 dependencies couldn't be built
building '/nix/store/r0gzxblzqrd9j8bhjvmdsn74q0ijyyjz-unit-console-getty.service-disabled.drv'...
cannot build derivation '/nix/store/y23sc4f13i67l89ci6faikyb4m69632l-nixos-system-mac-desk-19.03.172138.5c52b25283a.drv': 1 dependencies couldn't be built
error: build of '/nix/store/y23sc4f13i67l89ci6faikyb4m69632l-nixos-system-mac-desk-19.03.172138.5c52b25283a.drv' failed

nix-info for me is:
system: “x86_64-linux”,
multi-user?: yes,
version: nix-env (Nix) 2.2, channels(matthew): “”,
channels(root): “nixos-19.03.172138.5c52b25283a”,
nixpkgs: /nix/var/nix/profiles/per-user/root/channels/nixos

I can’t find anything regarding this via google so I was curious if others have this same problem or if it is just me. If somebody can try and install it and see if it succeeds for you I would be grateful.

1 Like

I had the same problem and tried a simple fix, though it still gets me wine errors whilst creating 64-bit volumes in POL (still no solution so far).

Thanks for the reply. Ill keep following the status on this, but until POL and Lutris are operational on Nixos ill have to keep Manjaro installed for those two programs specifically. Looking forward to moving all my machines to Nixos though as soon as I can.