Home-manager install fails cache.nix.org file not found

I have been trying to install home-manager and it fails when I try to update the channel
it says its a SSL cert issue but the actual issue seems to be that the cached file doesn’t exist on cache.nix.org. Anyway around this?

M1 MBP 13” 2020
ProductName: macOS
ProductVersion: 13.3.1
ProductVersionExtra: (a)
BuildVersion: 22E772610a

nix (Nix) 2.14.0
homebrew release-22.11
latest nix-darwin (at time of post)

> nix-channel --list                                                                                                   
darwin https://github.com/LnL7/nix-darwin/archive/master.tar.gz
home-manager https://github.com/nix-community/home-manager/archive/release-22.11.tar.gz
nixpkgs https://nixos.org/channels/nixpkgs-22.11-darwin
> nix-channel --update home-manager                                                                                   
error: unable to download 'https://cache.nixos.org/071dd34mmwqpkw26vk6ymc1g8pi72ppk.narinfo': Problem with the SSL CA cert (path? access rights?) (77)
error: program '/nix/store/4x9975rdvy4r0mybf8ic2ry9j5b0ag2g-nix-2.14.0/bin/nix-build' failed with exit code 1



Hi tried again today and it worked fine.
I presume someone either manual fixed it or the cache was automatically updated or something.
Thanks either-way.

>nix-channel --update home-manager   
this derivation will be built:
building '/nix/store/546bfda2z1aj4l7pci48l6nmygz0lbbh-home-manager-22.11.tar.gz.drv'...
unpacking channels...
> nix-channel --update                                                                                                 
unpacking channels...