How to Change Email Authentication Method Using Home Manager?

I would like to configure my Email accounts using the Home Manager module.
However, for one of the accounts I’m setting up, the authentication method is incorrectly identified as Kerberos / GSSAPI. It needs to be a normal password instead, but I cannot find a way to change this.

For reference, this is what the configuration should look like, and this is my (slightly adjusted) configuration of the account:

  Account = {
    address = "email@address.com";
    userName = "userName";
    realName = "Real Name";
    primary = false;
    flavor = "plain";
    passwordCommand = "super_secret_password_command";

    msmtp.enable = true;
    mbsync = {
      enable = true;
      create = "both";
      expunge = "both";
    };
    mu.enable = true;
    thunderbird.enable = true;

    imap = {
      host = "cyrus.ovgu.de";
      port = 143;
      tls.useStartTls = true;
    };
    smtp = {
      host = "mail.ovgu.de";
      port = 587;
      tls.useStartTls = true;
    };
  };

Thank you for your time :slight_smile: