I need help with nix-shell session, and a tutorial. Much Thanks!

Hello, I have about 3 months of Linux cli terminal experience.

My main goal is to complete the tutorial listed here:


I am here because I saw another user on this website get help, I would greatly appreciate the same.

I have made it to the 5th step, and I can’t open a nix shell session. I have installed nix as the command terminal instructions dictated, for multi user functionality. I did not install as root, and I have copied all commands from the tutorial, on step 2 I used the cat > nix.conf command and saved the file.

The error on step 5 is: command not found

when I type: whoami I get the user name of the computer.

Completing this tutorial is literally my obsession at this point, I can’t thank you enough for taking time to help me. PLEASE and THANK YOU!!

I’m not sure i really understand you.

On the second step, you copied the all the commands from the webpage? And then proceed to type cat > nix.conf into your terminal?

In that case your nix.conf file is empty. Which explains the rest of your mishap.
Can you confirm this by running cat nix.conf?

Hello Elorm,

I just tried what you suggested, I believe you were correct that I didn’t correctly create and then save the text in the file, now I believe I have created and successfully saved the text in the file correctly.

I have typed: cat nix.conf

it now shows the text it is supposed to from step 2 without any additional spaces or characters.

I just tried to open a nix-shell session and the same error of command not found has appeared.

I have also tried sudo nix-shell and this prompted the password before giving the same error of: command not found.

I am still stuck and do not know how to move forward.

I did follow the nix commands for the web page for multi user functionality.

Thank you!!

Run this and try again.
source $HOME/.nix-profile/etc/profile.d/nix.sh