Influxdb requires xen on aarch64 (Raspberry Pi 4)


I tried to get influxdb working on a Raspberry Pi 4:

services.influxdb = {
  enable = true;
  dataDir = /srv/influxdb;

However, nixos-rebuild test fails with

error: Package ‘xen-4.10.4’ in /nix/store/6ymm9bli0jsnf8i9is1y3i31ff4zh6bd-nixos-21.11pre326640.e544ee88fa4/nixos/pkgs/applications/virtualization/xen/generic.nix:248 is not supported on ‘aarch64-linux’, refusing to evaluate.

I tried to circumvent it by using a docker image:

virtualisation.oci-containers.containers = {
   "influxdb" = {
       image = "arm32v7/influxdb:1.7.8";
       ports = [
       volumes = [
       environment = {
         INFLUXDB_HTTP_BIND_ADDRESS = ":8086";

Here I have the strange problem that I can’t reach influxdb from outside on port 8086. Connection is only possible within the container on localhost.
Other container which are similar (e.g. Grafana) are reachable from outside without problems.

Any help either with the native influxdb or the docker solution is appreciated.