Inspiron 24 5410 AIO NixOS issues

I am attempting to install NixOS on a Inspiron 24 5410 AIO and when attempting to boot using the ISOs on the NixOS website ( Download Nix / NixOS | Nix & NixOS ) I get the boot menu then a blank screen. I tried nomodeset and other options in the boot menu - still nothing. I even attempted the “minimal” ISO and I still get a blank screen.

I went back through some old NixOS versions and found that I was able to boot into version 18.03 minimal ( nixos-minimal-18.03.133405.4d48e8106f9-x86_64-linux.iso ). However, the graphical version of 18.03 does not work with the system (probably due to using an old kernel?).

I am building a custom ISO to install on the system - so I can certainly make that but I am just wondering if anyone has any ideas of what I can look at of why it won’t boot. Using the ISOs off the website was just eliminating if there was something wrong with my NixOS ISO configuration. A blank screen makes it hard to get any sort of error message :frowning:

As a side note - Ubuntu 22.04 live does boot just fine so there is nothing weird with the system.