Install failed newest iso

Download the iso this morning and tried installing. It failed. I will try again when I get home from PT and see if formatting the partition to ext4 instead of xfs makes any difference.

Is there a sha file or md5 yo verify the file?

We need more details to help you. Hash is in the download page

Consider checking the partition table type

I knew that there would be more info needed. Gpt partition. Mounted boot as /boot/efi. And installed on / no separate partitions. Formatted my existing 32g swap partition as swap so nix could see it. I formatted / as xfs instead of ext4 was only difference from my plain nix install

XFS should be fine, and the info you’ve listed sounds pretty standard, shouldn’t be a problem there. Is there an error message you can post?

Also if you can post links to two files, /etc/nixos/configuration.nix and /etc/nixos/hardware-configuration.nix, created during installation, that would help too.

1 Like

I just installed it in a VM to try to learn. Between nix and learning how to use git, I’m keeping a headache these days

I’ve installed nixos quite a few times now without issue, until the other day I reinstalled on the same machine and rebooted to nothing, no systemd-boot or anything, so I tried again but this time using gparted I reformatted my fat32 partition and set the flags to boot esp, then in the installer I set it to mount on /boot, and the installed worked fine, maybe there’s a bug in the installer that sometimes doesn’t set the correct flag for the fat32 efi partition?

I have not encountered any issues during the installation process of NixOS, irrespective of the partition scheme employed. However, I wonder if you have disabled Secure Boot in your system’s BIOS settings? This could potentially impact the installation.