Intellij community crashing because of Javafx issue

Hello everyone,

I am having an issue using the AsciiDoctor plugin for Intellij (which is awesome) because of two issues:

  1. It says that stability issues may occur with pre-release versions of Java.
  2. Idea says that it can’t find the bundled Javafx and so can’t render the Asciidoctor in web view.

I have tried to fix the issue by following some guides online and installing the JetBrains.jdk package and referencing that for my project. However, the same issue happens and the application crashes. I can use Swing instead of Javafx but the application is very unstable and still crashes.

I tried to look into the issue and it appears that this package doesn’t use the normal bundled Jetbrains java runtime or JDK. However, I could be totally wrong in this assertation. Does anyone know how to fix this issue? In order to reproduce the issue you can do the following:

  1. create a project
  2. install the asciidoctor plugin
  3. create a .adoc file (or rename a file)

It will work for a little bit then crash, and then subsequently keeps crashing upon opening.