IntelliJ ends up using open jdk

Even I install it as (pkgs.jetbrains.idea-community.override { jdk = pkgs.jetbrains.jdk; }) I can see that at runtime it ends up running with openjdk8.
This is on 18.03. Rendering on a 4K display is currently extremely slow, and I’m hoping it will be fixed by using the correct jdk.

1 Like

The complete configuration I have so far looks like this: NixOS configuration for Lenovo P52s laptop · GitHub

Looks like there are two shortcuts produced by the package. One for starting it on open jdk, and one for the jetbrains jdk. The latter can be recognised by it not scaling the mouse pointer (Gnome3 otherwise does 2x scaling by default on this display, which openjdk apparently picks up on). And both jdks have super slow rendering. I’m running out of ideas on how to fix that.

What type of graphic card do you have? The default.nix enables allowUnfree for nvidia but then the X server is using videoDrivers = [ "intel" ];. Without the right 2D driver it might slow down the rendering quite a bit.

Can you give me the output of nix run nixpkgs.glxinfo -c glxinfo | grep -i render ?

@zimbatm I have a Quadro P500, which I have since learned is not even supported by the official Nvidia driver, or nouveau for that matter. I think I should have tried downloading IntelliJ from the jetbrains website as well, the one that comes with their custom jvm. That’s what I ended up doing on Fedora, which is what I have switched to since, and it (fast rendering of IntelliJ on a scaled display) works there. Another thing Fedora does different is that they use Wayland. I don’t know if that has any influence on this, but it does cope better with having an external display connected.

NixOS remains quite appealing to me for server work, but setting up a laptop just took more work and time than I had the energy to put in.

As long as you have a working setup that’s what counts. Nvidia and friends tend to test things on Fedora and Ubuntu so they have an advantage there for sure.