Is github source code search broken?

returns 0 results.

Have github disabled code searching for all the nixpkgs/NIXOS repo’s?


I had the same issue searching for makeRustPlatform yesterday.

1 Like

Yep. It broke at least a few weeks ago.




There’s a public Hound (code search engine) instance pointed at the NixOS org repos over at, I believe hosted by @grahamc. Thank you Graham.


Same. Also, if I run a code -filename:blah code search, none of the results populate.

There’s been a steady flow of weird breaks since they started mucking with it in mid December.


Just remember the cloud is other people computers, and github is no exception, i guess few of you remember when microsoft brought hotmail, and tried to port the whole system over to windows NT from unix…which was supporting 10 million users…HA HA HA HA !

Maybe they are currently migrating to windows server at this very moment, as history repeats itself…!!

big thanks to @grahamc for the HOUND!!!

1 Like

This annoys me every day. Unfortunately hound is unavailable at $work for some reason, it’s GitHub search or bust.

I assume, 2 years later, GitHub search for nixpkgs is still not working for anyone else either?

I am not sure I have done much with the ~new code search in nixpkgs, but I don’t think I recall the basics being terribly broken. Some aspects of new search annoy me, but others are good.

I haven’t made it through the waitlist for the new codesearch beta, but I get 0 code results for every search on nipxkgs. Several issues and commits but always 0 code results.

you need to find that reason.

Can you give me a specific example query?

People use GitHub’s search? I’ve always found it to be unusably useless.

$ rg -F pyproject.toml ~/git/nixpkgs | wc -l

This is how it looks for me…

Though I used for a while until I realised that the same functionality was available on-site as well. I thought it was released as a feature now.

Seems to still be beta or at least regular opt-in?

guthub should just buy and be done with it

It’s superior in every way and i think you can self host it too. Not sure if it has a nixos service, but it needs one.

Try “filename:pyproject”?

We couldn’t find any code matching ‘filename:pyproject’ in NixOS/nixpkgs


Tried on ~2~ EDIT:3 different browsers (FF, Safari, Brave), on 2 different GitHub accounts, and with and without a VPN, same results. Wonder what I’m doing wrong.

Did someone do something to my account?

It’s been this way for weeks / months, but within about an hour of the post above it’s working again.

Clicking the exact link from the screenshot above:

Yes, though probably unrelated to this thread – my account was enabled for the codesearch beta. An hour ago I clicked and it said I was still on the waitlist, now the new codesearch page loads.