Issue installing NixOS on a legacy notebook

I have a old laptop, a Dell XPS 9350 with a Intel i5-6200U, and I’m looking to give it a new life with NixOS. The installation worked alright, no issues at all, the problem is during boot. It get stuck with this message on screen:

EFI stub: Loaded initrd from LINUX_EFI_INITRD_MEDIA_GUID device path

Initially I thought it was related to the full disk encryption, then I did a fresh install without it, and I had the same error. Does anyone know what this could be?

I do not know the origin of the error, but, in case it helps you, I have been in a very similar situation and I solved my case preformatting the disk MBR (not EFI GPT, check also bios settings just in case).
More details, two approaches (and I adopted the second one to keep full encryption).

In both cases: 24.05 iso, GUI install, allow unfree, swap without hybernate, gnome… but maybe ok with other options.

Approach 1) manual partition during install, MBR, /boot partition unencrypted, all other partitions encrypted.

Approach 2) automatic partition, erase disk, disk encryption and the following is in the nix configuration:

boot.initrd.secrets = {"/crypto_keyfile.bin" = null ; };

Presumably this means you’re just booting an MBR system; EFI was still fairly new (at least in common consumer product use) in 2016, so it may come down to firmware issues making the EFI stub fail somehow indeed.

Before resorting to that I would however consider:

  1. Checking if dell has published any firmware updates for this laptop, and installing them if so
  2. Checking if you fare any better with nomodeset, just in case this is a graphics issue; you can add that to the kernel command line with the GRUB menu on startup
1 Like

I just checked on a machine I did an install on recently which was a similar era 2015/16. It was Dell XPS 9550 and the results were surprisingly good. Might be worth looking at reset firmware to defaults to, from memory the Dell have a lot of options in their firmware.