KDE causes locale errors


I have an unusual issue whereby I am getting locale’ errors that only occur with KDE installed, to the point it actually prevented me from launching an application (Prusa slicer).

The error I get is:
perl: warning: Setting locale failed. perl: warning: Please check that your locale settings: LANGUAGE = "en_GB:en_US", LC_ALL = (unset), LC_MONETARY = "en_GB.UTF-8", LC_MEASUREMENT = "en_GB.UTF-8", LC_TIME = "en_GG.UTF-8", LC_NUMERIC = "en_GB.UTF-8", LANG = "en_US.UTF-8" are supported and installed on your system. perl: warning: Falling back to a fallback locale ("en_US.UTF-8").

I have posted my config on my gist.
I can’t see anything that particularly jumps out in the config file that would cause this error, but I could be mistaken, I am still very new to Nix.

Thanks in advance for you help.


Hey there,
my locale settings look like this:

  	i18n.extraLocaleSettings = {
    	LC_ADDRESS = "de_DE.UTF-8";
    	LC_MEASUREMENT = "de_DE.UTF-8";
    	LC_MONETARY = "de_DE.UTF-8";
    	LC_NAME = "de_DE.UTF-8";
    	LC_NUMERIC = "de_DE.UTF-8";
    	LC_PAPER = "de_DE.UTF-8";
    	LC_TELEPHONE = "de_DE.UTF-8";
    	LC_TIME = "de_DE.UTF-8";

and I don’t encounter any issues. Hope it helps


Thanks for you help @lovirent , and thanks for everyone for reading.

It turns out this was a bit of a red herring. I created a dummy account, and logged into plasma with it.
The problem did not transfer over, so the issue was not global.

It turns out my ~/.config/plasma-localerc was the issue. I just deleted it, and all seems well now.



1 Like