Laptop screen not detected

I am facing a problem I don’t know how to debug. I have a laptop with a recent nvidia video card. Laptop works with external display just fine, but doesn’t seem to detect the internal display (xrandr, nvidia settings, plasma display settings only see the external display). What would be the next step to troubleshot this?

Not a solution, but potentially related to #165719. I have the opposite problem atm, my external HDMI port is no longer working.

I also posted on the Nvidia forums since there aren’t any good leads in the issue thread. I’ve got to generate a bug report for the devs and hopefully they can give some deeper insight.

For now I would check the syslog to see if you have the same error in your log, or if it’s something completely different.

In a typical linux desktop fashion, you don’t diagnose issues, you just apply random solutions until something sticks. In my case,

I needed to change

  services.xserver.videoDrivers = [ "nvidia" ];


  services.xserver.videoDrivers = [ "intel" "nvidia" ];

This makes sense I think – internal display should be plugged into via intel chip or something. Updated the wiki to mention this: Nvidia - NixOS Wiki

1 Like

This is pretty strange, I made the same edit on my configuration just to see if it might help but nothing changed. And I mean nothing, the current generation didn’t even change, so at least on my machine, this change is a no-op (i.e., system drv hash stays the same)

Hm, yeah, I actually fail to reproduce the effect of adding an intel driver now: my built-in display no longer works :laughing: so perhaps this was some unrelated change, will revert the wiki change :weary:

Finally solved the problem, it was 12th gen intel (Alder lake) problems: