Latest image fails to install (22.05)

tried installing plasma several times. always errors out, unable to connect to server.

*also after failed install, running installer again forces manual partitioning. no option to erase disk anymore without a restart.

Quickly skimming the log, it seems as if you missed to configure the network, or perhaps the binary cache was/is not reachable in your region currently/when you tried.

network is working fine, I was able to use firefox to post the error message from the live image.
There just seems to be bugs in the installer. Sometimes, it can’t even detect that there is an internet connection.

There is a known bug, that you have to restart it after network connection has been established.

So far I assumed this was only about displaying of connectivity status, though perhaps it’s a deeper problem?

don’t know exactly where the problem is. sometimes it installs up to around 40% before the network connection error. sometimes it tells me as soon as i start the installer that it can’t connect to the internet. when this happens, even a reboot doesn’t fix the problem.
meanwhile during the live image, i can use firefox to access the internet. though yesterday when i was trying it, firefox had trouble connecting to, even though the rest of the internet was fine. could be a problem with too much server traffic. maybe having mirrors could solve this issue. i’m speaking naively of course, maybe there already are mirrors.

Most, if not all, of is covered by fastly CDN.

It is known that the infrastructure had some problems in the US recently and also India complaints about problems regularly.

Perhaps any if these is relevant to you?

I’m in Canada, but close enough to the USA that it probably uses the same servers.

I’ve had it where DNS wasn’t working properly, but firefox has a bunch of “failbacks” to make the web browsing experience less surprising to users so it was transparently fixing the DNS issue. I would try using curl to ensure that networking is working as intended.

If that’s the problem, I wouldn’t know what to do to fix it. I expect any live environment (or terminal based installers) to be able to figure out how to connect to the internet without any involvement from me. I know I was able to install an older version of NixOS a few weeks ago, but I wasn’t experienced enough with layered operating systems (and getting Nvidia to work on linux) to understand it back then.

I tried it again today. Same problem. It gets to the point where it can’t download from the server.
I ran some curl tests in Konsole and those worked without any problems. I think the problem is with either the servers local to Toronto time zone, or with the installer.

Does a “manual” install succeed?

I don’t have the time or desire to mess around with a manual install. After installing linux manually a few times, the novelty wears off.

The latest 1818 image also fails to install. I just tried the KDE version, I suspect the Gnome version will give the same error as before.

The graphical installer is a red herring.

After you went through it, you will manage your system the manual way anyway!

NixOS lives from editing the text based configuration file and rebuilding the system from that. There is no nice GUI to edit it.

Manual installation for nixos is usually just creating partitions, mount them, generate config, adjust name of the first user, locale settings and then run nixos-install.

That may be, but the installer is there to get a quick base system setup from which the user can build upon.

This was the use case for me. I want the system up and running to compare the workflow with Fedora Silverblue.

NixOs failing on install adds a point of friction that does not give me much confidence on the system as a whole.

1 Like

I’d honestly assume you’ll have similar problems with updates later, this seems like a networking issue of some sort.

It should be noted that nobody else has reported this so far to my knowledge, and we’ve had quite an influx of less experienced users after the graphical installer was added. It’s an unfortunate case of “works for most of us”.

Obviously there’s no obligation, but in the spirit of free software, it’d be great if you could help figure out what the issue is - then someone can get around to fixing it, or at least document what quirks might cause issues for the installer, so the next person doesn’t have these problems. The graphical installer is there for a reason, but @NobbZ is right in that it hides a lot of detail, making it hard to debug as-is.

A simpler debugging step might be to run

watch --errexit -n 1 curl 

and just watch it to see if it’s flaky (if it ever exits by itself, but resolves correctly at least once, that points to networking issues).

I’d also give nix-channel --update a go, just in case your channels are outdated (though I don’t know why the cache would no longer have those contents, so I doubt that will help, and even then nix should just get around to building them itself).

While I understand the frustration, keep in mind it’s just a blip in a very large system, and may even lie with your ISP or fastly, completely out of the control of the NixOS maintainers. Maybe you’re sharing an IP with a spambot, and fastly is rate limiting you to avoid DoS attacks, for example.

Updating the nix-channel didn’t have any effect as you suspected.
watching the cache file at nixos doesn’t give me anything unusual. The alignment isn’t great, but I believe it downloaded something that’s 506 bytes and the speed fields keeps updating. I just ctrl-c out of it after a few minutes.

up to this point, I’ve been attempting to install on a 500GB SATA SSD connected to an external mount. And the process was failing as stated in this thread.
I decided to try again, but this time I inserted a 4tb HDD and installed it onto a 1tb partition on that HD. All the “PYTHON JOBs” that failed previously are working and the OS is currently installing normally.

The external HDD is too slow to use as an OS system of course, but I had to try it in a process of elimination problem solving.

Now, can anyone advise me on how to nudge NixOS to install on the external SATA SSD? I have installed dozens of Linux distros with this method before, all with success.

If I understand correctly, you want to install NixOS on a different disk than the one your current OS is installed on. That’s quite easy.

Partition that disk the way you want. Here are my partitions (I’m not recommending you do the same; I’m just listing them so you can match them up to the commands below):

Device              Start        End    Sectors  Size Type
/dev/nvme1n1p1       2048    4196351    4194304    2G EFI System
/dev/nvme1n1p2 3841492992 3907028991   65536000 31.3G Linux swap
/dev/nvme1n1p3    4196352 3841492991 3837296640  1.8T Linux filesystem

Now we create a mountpoint, and mount all the partitions under it:

mkdir /mnt
mount /dev/nvme1n1p3 /mnt
ls /mnt
mkdir -p /mnt/boot
mount /dev/nvme1n1p1 /mnt/boot
swapon /dev/nvme1n1p2

Now we’re ready to generate the configuration based on those partitions.

nixos-generate-config --root /mnt

Make any modifications you want to the configuration (e.g. add more packages). Now you can boot off of that disk instead.