Lftp fails to connect via ftps

I’m trying to backup to my webspace via ftps using duply (frontend for duplicity) and lftp.

Using ftp it works fine, so my settings are correct. Also, with deja-dup (GUI frontend for duplicity) i can use ftps with no problem so my webspace supports ftps.

However, if i tell duply to use ftps it yields:

--- Start running command BKP at 2022-12-06 06:45:10.325 ---
LFTP version is 4.9.2
Reading globbing filelist /home/sperber/.duply/manitu/exclude
Attempt of list Nr. 1 failed. BackendException: Error running 'lftp -c "source /tmp/duplicity-i2x2ik4_-tempdir/mkstemp-riha_xf1-1; ( cdduply/ && ls ) || ( mkdir -p duply/ && cd duply/ && ls )"': returned 1, with output:

cd: Fatal error: gnutls_handshake: An unexpected TLS packet was received.
mkdir: Fatal error: gnutls_handshake: An unexpected TLS packet was received.

Has someone an idea how i can fix this?

How do you configure the server? People reported here a possible fix on the configuration ofthe server ssl - Ubuntu - lftp will not connect to ftps site (Fatal error: gnutls_handshake: An unexpected TLS packet was received.) - Unix & Linux Stack Exchange

See also ftps - One more Fatal error: gnutls_handshake: A TLS packet with unexpected length was received - Stack Overflow

I don’t have a server or access to the server configuration but can only access the webspace (i don’t know the correct term for this. It is “webspace only” on shared servers of the provider). I saw threads like those you sent me but they all reference changing the settings of the server or of lftp. As i can’t change the settings of the server and, as far as i know, also not of lftp as it is handled by duply, they didn’t really help me.

Using ftp shouldn’t be too bad as duplicity is uploading already encrypted data, so the missing transport encryption shouldn’t be a major issue. I still would like to use it though.

Do you have further suggestions or do you know how to pass arguments to lftp via duply?

I’ve never used these software, but seems like duplicity uses it’s own configuration method as reported here. It seems that to force ssl you should use ftpes:// instead of ftps:// as can be seen from the code.

1 Like

ftpes is working, thank you very much for the hint. It isn’t mentioned in the duplcity manual, that’s why i didn’t know about it.

1 Like