New User Having Issues

I tried installing NixOS from the graphical boot CD. Followed the instructions for UEFI (GPT), no errors.

Rebooted: no boot.

I do not know if I can boot UEFI or if I have to use MBR. Why doesn’t the documentation give any guidance? I am a very experienced developer but I don’t know anything about UEFI. Why do you just assume everyone does? How is it not clear to you that the average very technical person is not going to know what UEFI is and when to use it? Is it hardware-dependent? Is my laptop UEFI-capable? How would I know?

This is pretty typical of my experience with NixOS so far. What am I supposed to do, become and expert in everything before I use it? No one has time to become an expert in everything.

Also, tried to connect to my WiFi from the Boot CD. Got some message about some sort of encryption wallet, that then popped an error window. Presumably this was to store my WiFi password. The window went away when I closed the error message popup. Never came back. Could not log on to WiFi network because, apparently, it didn’t offer up a password.

What the heck, now I have to become an expert in encryption wallets and what might go wrong with them just to connect to my WiFi network?

I really like the idea of NixOS, but you guys are not explaining anything. You’ve gotta throw the user a bone here.

Edit: After messing around endlessly with this KDE Wallet encryption thing, I changed the WiFi settings to ask for a password every time… but it does not ask for a password. KDE Wallet says “there are no encryption keys… create some” or something like that. But I have no idea how to create encryption keys for KDE Wallet nor any idea why I would want to. Only after closing KDE Wallet does a dialog pop up prompting me for my WiFi password (and then connects successfully).

Are you guys actually some sort of sadistic cult or something? Why would you put a user through that just to connect to a WiFi network? This seems like pretty basic functionality… why doesn’t it work?

Edit2: OK, I tried the MBR configuration and it worked. Booted to a command line. Says for help run nixos-help. So I do that and it says can’t run browser. Tells me to set $Browser.

OK, so I understand that is an environment variable, but how do I set it, and to what? Without Help, I’m not likely to find out, but I can’t run Help because…

Also, I don’t know how to start a graphical environment. There was a thing that the boot CD told me I could type, and I did. But it was a weird thing and I don’t remember it. And I can’t get help…

You guys are just trolling me now, right? Does this distro just exist to be psycho-level mean and nasty to people?

Edit3: I edited the /etc/nixos/configuration.nix or whatever and I added the lines to install a graphical environment. No idea which one to use, so I tried plasma5 or whatever. So now I have to be an expert in which desktop manager to use? You can’t install a default? There was a default on the boot CD, why not use that?

Then I issued the nixos-rebuild switch command or whatever, and it rebuilds, but all of the downloads fail because I am not on the network. Because my WiFi is not connected. And I have absolutely no idea how to do that from the command line… and there’s nothing in the NixOS manual about that. Or is there? I can’t read the manual… see above!

Couldn’t you guys configure the defaults to install some sort of minimal graphical environment so I can read the manual and get on the network? Then I could change the config file to whatever.

This is just cruel and unusual, really.

Edit4: Tried to use the line in the manual: wpa_supplicant -B -i interface -c <(wpa_passphrase ‘SSID’ ‘key’) to start the network manually without a GUI, but it doesn’t work. I don’t know what ‘key’ is. It’s not the wpa passphrase, obviously, but what is it? I don’t know of any other key. You need to give an example of this. Say, "If your SSID is foo and your passphrase is bar, and your key is (whatever it is, who knows?) then type this…

Are you guys allergic to specific examples or something?

Anyway, rebooted the boot CD and did a reinstall to get the GUI up, but there’s no WiFi dialog in the lower right like there was in the boot CD, even though I enabled it in configuration.nix. Also the trackpad doesn’t work. Every time I stop moving the mouse it restarts in another part of the screen. It didn’t do this in the boot CD version.

If you guys already know how to configure the mouse correctly (because you did it for the boot CD) why keep it a secret? WHY NOT INSTALL THE SAME STUFF YOU HAD ON THE BOOT CD? IT MAKES NO SENSE!!! Why not get me up and running with the same desktop and services as a starting point, so I can then edit the configuration file and do what I want? Then if WiFi goes away, it’s because I commented it out in the config file. If the mouse doesn’t work right, it’s because I changed something and I can change it back.

I am sorry to say this, but there’s something wrong with whomever put this together. It’s just useless, frustrating and time-consuming.

1 Like

Although I do love the design of NixOS and consider it as the best distro I’ve used so far, it is painful to get start with it. When I recommend it to my mates they always have to reinstall several times to figure out which necessary part is missing. This is embarrassing. I think a bloated but workable default system will be much better than a simple system which can not connect to WiFi. Since NixOS is easy to prune…

Edit: effort has been taken to make a better installer, although I didn’t save the links, they do exist in discourse and github issues. Developers have realize the problem and are trying to improve, calm down friend :hugs:

I’m not a “very experienced developer “, I’m just a dumb old truck driver. I found that having the help manual open in my phone while sorting out the installation was very helpful.

As NixOS goes about things in a very different way than other distros, (kind of the point, really), it did take me a couple of attempts to get the installation right to the point of having a fully functioning system with a GUI desktop environment (Gnome). It was/is a learning experience, which was why I tried it in the first place.

I’ve had several problems/questions regarding configuring and using the Nix system along the way, and found this community to be very patient and helpful when I asked specific questions, as opposed to ranting.

I wanted to try NixOS specifically because it’s different. If it was the same as all of the others I would likely have never tried it. After getting it installed and using it, I see the beauty of having a system that can be easily configured and reproduced via a single configuration file.

Every issue you mentioned has an easy solution if you’re really interested. Perhaps you should just tackle them one at a time.

For connectivity might I suggest installing either networkmanager or wicd to make connecting a bit easier?


Welcome to the community. I hope you get your configuration figured out!

One small tip:

@loka does make a good point, is there a configuration file that can just be copied into configuration.nix that can be copied directly to reproduce the livecd system? I suspect it is importing the installer module, but I don’t have a way to check right now.

Newcomers might find it easier to trim down from an existing system then to build up from a minimal one.

1 Like

Here it is: nixpkgs/installation-cd-graphical-kde.nix at c89cbdcd48bf11fbb9fb9ebaeaa59aad566a8648 · NixOS/nixpkgs · GitHub

I don’t think it useful to reproduce the exact installer profile but maybe provide some useful presets in the configuration generator.

And of course the really important info isn’t on the router, because the manufacturer assumes that you use Windows which takes care of it for you.

So you spend hours finding the info, then trying to get the syntax right… so much for “doing everything myself”.

most networking protocols are usually cross platform. However, I’ll agree that some tooling around linux (E.g. wpa_supplicant) isn’t super user friendly