NFS share stopped working with 22.05

I have the following two NFS shares in my config:

The data-share (the first one) still works without a problem.
The restic-server share however stopped working with 22.05.

I don’t really see what the problem is, it just times out. Both shares have the same permission and are on the same server.

When I revert the restic server back to 21.11 it starts working again.

I tried to use the same options as for the data-share but for some reason it doesn’t work.
Specifying the NFS version didn’t help either.

Couple of things:

  1. the options passed to mount are not the same. Might be work trying to align them to remove variables.
  2. what happens when you try to manually mount using mount?

Thank you for your input.

I found the solution today on the Ubuntu and QNAP forums.
You have to explicitly set nfsvers=4.0 otherwise it doesn’t work with the current version of the QNAP os (5.0.x) .
However, I don’t know why the data-share share worked without that option.