Nix os not booting after install


I have used rufus to create install media with uefi and gpt options enabled.
I can boot into the installer with secure boot turned of as well as support for legacy devices disabled
This is on a HP t640 thin client
Windows and ubuntu boot fine with the bios setings

however, when I install nix os and restart there is no boot media found.

Any help would be appreciated.

Can you post your configuration.nix and hardware-configuration.nix for context? Are you running the installer in EFI or bios mode?

Thanks for the reply

I went back to ubuntu, I will install nixos again. Can you pls assist with how I get the configuration.nix and hardware.nix files, when I get an error message saying no boot media found on the disk

I tried both modes.

When I ran the installer for ubuntu after I installed nixos, but could not boot, the ubuntu installer picked up the Nixos install and the option to install Ubuntu alongside was available.

This was my first time trying to install Nix OS.