NixOS 22.05 released

Hi everyone,

I am pleased to announce the general availability of NixOS 22.05 and nixpkgs 22.05, both codenamed “Quokka”!
Important links:

This is of course not my work, I am just the one who pushed the branch :wink: The release was supported by 1611 contributors who made 46727 commits.
The release announcement contains more numbers and details that I will not repeat here.

A highlight of the release is Nix 2.8, which brings experimental flakes support for the default installed Nix version, along with tonnes of fixes, features and general improvements, like @pennae’s work to improve performance.

The other notable change is the new graphical installer, which @vlinkz led the integration of with @davidak doing a lot of additional work. This feature, enabled by default in the graphical ISOs, will hopefully make initial setup easier for new users and existing users setting up new NixOS machines.

Of course, these are just two things I want to highlight here. Not to mention the countless improvements, bug fixes and new features that have also gone into this release. I would like to thank every single contributor who has contributed to this release. Every NixOS release is an improvement over the previous one and I am already looking forward to the improvements of 22.11.

Please remember that the new release also means that 21.11 channel is now obsolete and will only be updated for an another month.

I would also like to thank @hexa and @aanderse for supporting me during the release process and answering my countless questions, as well as @Mic92 who worked on the release note in his role as release editor.

Enjoy the new stable branch, everyone :tada:


Congrats on the release and huge thank you to everyone involved!


@dasj I think there’s a typo in the release announcement-link, it currently points to nixos.orgb :slight_smile:


I believe still needs some updating as it still mentions

the NixOS 21.11 release

Thanks to @das_j for stepping up to be RM and doing an excellent job.

Also, shout out to @Mic92 for making the release notes much more readable.

Not sure if you all want to continue the tradition, but I liked doing a “release retrospective” to just reflect upon the release and make improvements for next time.


Should have mentioned this… I plan to do one if you tell me what I’m supposed to do there :wink:


Unfortunately I wasn’t able to record any of the previous ones (because obs suddenly didn’t work right before recording :(), but I can help facilitate it if necessary. I’ll DM you more specific instructions.

1 Like

Oh wow, the graphical installer went completely under my radar. Wonder if that warrants a separate announcement, and maybe even some dedicated marketing - this existing now might well sway some people who’ve been too lazy to fight the TTY :slight_smile:


Wait, isn’t there a tradition that .05 releases are released in June? This is admirably early!


smoothest upgrade ever since starting using Nix 2 years ago, almost no config changes needed, nice! Kudo!


Not smooth for me. I updated the nixos channel and the home-manager channel.
nixos-rebuild switch --upgrade worked fine for me, but when trying home-manager switch, I get the following errors:

error: builder for '/nix/store/d34v3k6nm47c0xy9l0wzfa64zgw7dd9z-dunst.service.drv' failed to produce output path for output 'out' at '/nix/store/d34v3k6nm47c0xy9l0wzfa64zgw7dd9z-dunst.service.drv.chroot/nix/store/ivwp5fq8h24w63jhfbr5g0n8wzxydghc-dunst.service'
copying path '/nix/store/prq4a3q6ahh65xjzk1dlay6ymb41digq-cmake-3.22.3' from ''...
copying path '/nix/store/9nf57l41icap05zjxxvsri2wxx600v0m-hook' from ''...
copying path '/nix/store/mrwwbcps3kc9cqvabr7rrjm1i6b2vgaz-jasper-2.0.32' from ''...
error: 1 dependencies of derivation '/nix/store/7697ky499krj2rlqzm73m44kplyl53a1-home-manager-files.drv' failed to build
error: 1 dependencies of derivation '/nix/store/yaddhbk4cz7nmfynzjb54ywkwiikr0i3-home-manager-generation.drv' failed to build

Any ideas on how to fix this?

Check logs. generally, its a good idea to build derivations with -L flag

This may be a shot in the dark but I had very very similar errors when I tried to update, turns out I forgot to update my home-manager channel to 22.05. Hope it helps!

Since upgrading to NixOS 22.05 I see the packagekit service crashing: packagekit service crashes in nixos-22.05 · Issue #178163 · NixOS/nixpkgs · GitHub.

We just released the nixos-mailserver branch nixos-22.05.

Thank you NixOS “releasers” for this 22.05 which works like a charm: our nixos-mailserver release has been pretty easy to do!

1 Like
Hosted by Flying Circus.